Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 21901 - Allow copy from property in r/o state
Allow copy from property in r/o state
Status: RESOLVED DUPLICATE of bug 49441
Product: platform
Classification: Unclassified
Component: Explorer
3.x
All All
: P3 (vote)
: 6.x
Assigned To: Martin Krauskopf
issues@platform
:
Depends on: 29447
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-27 00:06 UTC by Rochelle Raccah
Modified: 2008-12-22 21:42 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rochelle Raccah 2002-03-27 00:06:05 UTC
For properties which have a type (field type, method return type, etc.), the
enabled version in the java module shows an editable drop down.  In the class
module, these are only browsed, never edited, so they are always disabled.  I
was examining the contents of a jar file and wanted to copy/paste the class
name.  I was able to do that because of the "...".  For the types, there is no
"..." so I could not copy/paste.  A few comments:

1) Maybe copy/paste should be available directly from the property sheet?
2) Copy/paste for the type editors should be made available via the "...".
3) Java module should be checked for the same case if a property sheet is
disabled for some other reason (i.e. readonly file)
Comment 1 Jan Becicka 2002-04-30 14:36:15 UTC
I'm changing subcomponent to UI.
This behavior is as designed IMHO, isn't it, ui guys?
Comment 2 Svata Dedic 2002-06-10 10:09:38 UTC
I believe that this should be solved (or supported) in OpenAPIs: All
the properties have both the "normal" Property Editor (capable of
getAsText) and the custom PropertyEditor registered for the property's
type.
I believe that the OpenIDE framework could permit displaying of Custom
property editor (blocking changes in the supplied PropertyModel),
possibly notifying the Editor about the model's r/o state.
It could be also possible to allow Copy over a r/o property value,
copying its value as text, at least.
Those two requests seem more like RFEs, not defects, to me.
Comment 3 Marian Mirilovic 2002-06-10 15:19:29 UTC
Assigning to Ales (or Jirka) ?
Comment 4 akemr 2002-06-10 15:48:57 UTC
Ad 1. It works. Custom PE can be displayed even in r/o mode.
But Type editor has no custom PE.

Ad 2. Allow copy over r/o state - I'm changing it to ENHANCEMENT and
reassign to Jirka - property sheet owner.
Comment 5 Rochelle Raccah 2002-06-10 18:36:10 UTC
So this issue is now capturing the 2nd comment - make it work with 
copy/paste.  However, haven't we lost the 1st comment - type editor is 
missing custom PE?
Comment 6 Marek Grummich 2002-07-22 11:15:12 UTC
Set target milestone to TBD
Comment 7 Marek Grummich 2002-07-22 11:18:19 UTC
Set target milestone to TBD
Comment 8 Jiri Rechtacek 2003-03-24 15:43:22 UTC
reassigning to Tim as property sheet's owner
Comment 9 _ tboudreau 2003-03-24 19:59:52 UTC
Adding to propertysheet rewrite umbrella issue.  It should be 
pretty painless (I hope) to support copy/paste on read-only properties
once propertysheet is rewritten.
Comment 10 _ tboudreau 2003-05-19 02:04:06 UTC
Note that there is no copy menu item specified in the UI
spec for the new property sheet.  Perhaps the HIE team
would like to consider this?
Comment 11 _ tboudreau 2003-11-20 21:12:17 UTC
Question:  What exactly do we want to copy here?  There are a few options:
 - The property name
 - The property value
 - The property value as text (via the editor's getAsText method)
 - The result of getJavaInitializationString() on the property
editor(if any)

I can't say I've worked heavily with cut/paste, so I'm not sure what
the options are - but what are we really after here?
Comment 12 Rochelle Raccah 2003-11-20 21:35:39 UTC
I was trying to copy the property value, I guess as text makes the 
most sense.
Comment 13 Martin Krauskopf 2004-11-23 16:06:19 UTC
This issue will be solved as part of 49441, since it's something like
little umbrella for this one. I put the link to this discussion there.

*** This issue has been marked as a duplicate of 49441 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo