Bug 218872 - LowPerformance took 9173 ms.
LowPerformance took 9173 ms.
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Navigation
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Alexander Simon
issues@cnd
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 04:23 UTC by Exceptions Reporter
Modified: 2012-10-26 01:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (105.18 KB, application/nps)
2012-09-24 04:23 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-09-24 04:23:43 UTC
This bug was originally marked as duplicate of bug 216350, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build nbms-and-javadoc-9445-on-20120921)
VM: Java HotSpot(TM) Client VM, 20.10-b01, Java(TM) SE Runtime Environment, 1.6.0_35-b10
OS: Windows 7

User Comments:
GUEST: start ide that open c++ project



Maximum slowness yet reported was 9173 ms, average is 9173
Comment 1 Exceptions Reporter 2012-09-24 04:23:46 UTC
Created attachment 124779 [details]
nps snapshot
Comment 2 Alexander Simon 2012-10-24 06:24:01 UTC
Problem in the method: org.netbeans.modules.cnd.qnavigator.navigator.CppDeclarationNode.getIcon()
Method is called from EDT and can take a time.
Comment 3 Alexander Simon 2012-10-25 13:16:22 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/22d0e931af45
Comment 4 Quality Engineering 2012-10-26 01:28:23 UTC
Integrated into 'main-golden', will be available in build *201210260001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/22d0e931af45
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #218872 LowPerformance took 9173 ms.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo