Bug 218447 - [73cat] Copy/Paste empty or retains old clipboard data
[73cat] Copy/Paste empty or retains old clipboard data
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
7.3
All All
: P3 with 2 votes (vote)
: 7.3.1
Assigned To: Jaroslav Tulach
issues@platform
:
: 204957 205697 217115 218024 218395 218460 218477 218688 (view as bug list)
Depends on: 88161
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 08:41 UTC by bht
Modified: 2013-09-13 16:26 UTC (History)
19 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (329.64 KB, text/plain)
2012-09-17 08:41 UTC, bht
Details
IDE log (905.08 KB, text/plain)
2012-09-17 10:32 UTC, misterm
Details
trying to paste code (27.82 KB, application/octet-stream)
2012-12-30 22:09 UTC, ceklock
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bht 2012-09-17 08:41:09 UTC
Created attachment 124433 [details]
messages.log

Build 201209150001

During multiple sessions, the IDE refuses to paste data that is copied to the clipboard by other applications.


What I did during the session that is recorded in the attached log file:
- Start up the IDE
- copy a file name to the clibboard e.g. C:\Program Files\NetBeans Dev 201209150001\etc\netbeans.conf
- Menu|File|Open File
- click in the File name text box
- press [Ctrl+V]

What is copied:

some old data from what appears to be the copy result from a previous session, and appended to it, the value copied.

I tried to copy this concatenated result as a whole but it did not work either.
Comment 1 Stanislav Aubrecht 2012-09-17 09:58:24 UTC
*** Bug 218460 has been marked as a duplicate of this bug. ***
Comment 2 misterm 2012-09-17 10:00:45 UTC
This also occurs the other way around and has become increasingly common since 7.3. Before, it would happen sparingly, now I have to restart the IDE a few times during working days because of this issue.
Comment 3 misterm 2012-09-17 10:30:38 UTC
Another instance. First paste worked, second failed (pasted previously copied content). This is very common nowadays.
Comment 4 misterm 2012-09-17 10:32:12 UTC
Created attachment 124442 [details]
IDE log
Comment 5 Jesse Glick 2012-09-17 15:13:50 UTC
*** Bug 218395 has been marked as a duplicate of this bug. ***
Comment 6 Jaroslav Tulach 2012-09-18 07:45:43 UTC
*** Bug 218466 has been marked as a duplicate of this bug. ***
Comment 7 Jaroslav Tulach 2012-09-18 07:51:56 UTC
Fixed in 930d40bba6d5 - use 
$ hg pull -r 930d40bba6d5 http://hg.netbeans.org/ergonomics
to get the changes and test them asap.
Comment 8 Milutin Kristofic 2012-09-18 12:50:21 UTC
*** Bug 218370 has been marked as a duplicate of this bug. ***
Comment 9 David Strupl 2012-09-18 13:24:46 UTC
*** Bug 218024 has been marked as a duplicate of this bug. ***
Comment 10 Marian Mirilovic 2012-09-18 14:59:42 UTC
*** Bug 218477 has been marked as a duplicate of this bug. ***
Comment 11 Jesse Glick 2012-09-18 16:50:03 UTC
So far seems better with ergonomics #930d40bba6d5 (applied as an MQ patch atop core-main #d45652dc094c).
Comment 12 misterm 2012-09-18 17:36:08 UTC
Haven't applied the patch, but -J-Dnetbeans.slow.system.clipboard.hack=false makes it faster than ever.
Comment 13 Quality Engineering 2012-09-19 03:05:04 UTC
Integrated into 'main-golden', will be available in build *201209190001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/930d40bba6d5
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #218447: More stateless NbClipboard. Rather than having one task and shared data, let's create one task for getting and one for setting the clipboard. Make sure we don't block refreshing while delivering changes after direct setContents call.
Comment 14 Stanislav Aubrecht 2012-09-19 13:14:52 UTC
*** Bug 205697 has been marked as a duplicate of this bug. ***
Comment 15 mienamoo 2012-09-19 13:40:25 UTC
Looks good so far. I haven't experienced any issues with build 201209190001 yet. :)
Comment 16 Marian Mirilovic 2012-09-20 13:08:21 UTC
*** Bug 218688 has been marked as a duplicate of this bug. ***
Comment 17 kosmonaffft 2012-09-20 13:16:20 UTC
Works in 20120920001.
Comment 18 medeag 2012-09-25 16:15:05 UTC
Issue partially remains in 7.3 beta, i can not copy/paste e.g. product version  etc from about window, on windows 7 64bit, jdk 7... the copy/paste from edit works perfectly.
Comment 19 medeag 2012-09-26 07:46:34 UTC
today this worked, so i'm marking this issue as resolved, until i find any clue why it doesn't worked yesterday.
Comment 20 Alexander Kouznetsov 2012-10-03 09:12:57 UTC
*** Bug 217115 has been marked as a duplicate of this bug. ***
Comment 21 tim_sa 2012-10-25 08:17:09 UTC
I've seen a recurrence of this bug in build 201210240001

please see http://www.screencast-o-matic.com/watch/cl6TjhS4G for a screencast illustration.
Comment 22 Jaroslav Tulach 2012-10-27 05:27:49 UTC
I don't have a reason to believe we are facing the same bug. Anyway I asked for log files. Where do you have the log files with appropriate logging turned on?

Your last comment deserves invalid status, but I can't do it, as the previous reports were fine and got fixed. Marking fixed again.

Rather than opening a P1 bug on behalf of an animated movie, consider opening new bug and trying to make your report proper!
Comment 23 ceklock 2012-12-07 23:47:44 UTC
*** Bug 204957 has been marked as a duplicate of this bug. ***
Comment 24 ceklock 2012-12-07 23:52:49 UTC
I had this bug now with NetBeans 7.2.1. I can't paste in NetBeans the text that I copied from outside. I had to close and reopen NetBeans to paste the text.


Product Version: NetBeans IDE 7.2.1 (Build 201210100934)
Java: 1.7.0_09; Java HotSpot(TM) Server VM 23.5-b02
System: Windows 7 version 6.1 running on x86; Cp1252; en_BR (nb)
Comment 25 ceklock 2012-12-30 22:09:40 UTC
Created attachment 129770 [details]
trying to paste code

trying to paste code that I copied from external source to inside netbeans, but netbeans uses the last code that I copied inside netbeans...
Comment 26 jason3421 2013-01-29 18:56:29 UTC
I'm definitely seeing this in 7.2.1. I have dual monitors, but otherwise a typical setup. Pasting into notepad works, pasting into netbeans keeps pasting old stale data. I have found a way around this, if I copy something from netbeans and paste it back into netbeans, then copy something from say notepad, then I can paste that new String from notepad into netbeans. No need to restart!

Product Version: NetBeans IDE 7.2.1 (Build 201210100934)
Java: 1.7.0_09; Java HotSpot(TM) 64-Bit Server VM 23.5-b02
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
User directory: C:\Users\jason.handuber\AppData\Roaming\NetBeans\7.2.1
Cache directory: C:\X\Tools\NetbeansCache

How do I enable the "appropriate logging" and where do those log files go?
Comment 27 Jaroslav Tulach 2013-01-31 08:27:17 UTC
Reopen when you see the problem in 7.3RC1.

Btw. this bug has P1 priority and thus it technically prevents release of 7.3. Reopening such bug with an outdated observation made while using previous version of the product is not fair.

> How do I enable the "appropriate logging" and where do those log files go?

-J-Dorg.netbeans.NbClipboard.level=FINE
http://wiki.netbeans.org/FaqLogMessagesFile
Comment 28 pbelbin 2013-04-18 22:34:42 UTC
I am using NetBeans 7.3 on Windows 7 x64 with jdk 7u17.

pasting text into the editor text windows is pasting text that was previously in the copy/paste buffer.

If I paste the expected text into notepad.exe, then copy it from there, I can successfully paste the intended text into the NetBeans window successfully.
Comment 29 Jaroslav Tulach 2013-04-19 04:23:35 UTC
Without log files, there is not much I can do with your inquiry.
Comment 30 ceklock 2013-09-13 16:26:03 UTC
(In reply to Jaroslav Tulach from comment #29)
> Without log files, there is not much I can do with your inquiry.

Lol... never happened to you?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo