Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 218393 - IllegalArgumentException: URI has an authority component
IllegalArgumentException: URI has an authority component
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Debugger
7.2
All All
: P3 (vote)
: 7.3
Assigned To: Ondrej Brejla
issues@php
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 16:02 UTC by Exceptions Reporter
Modified: 2012-09-18 02:10 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.54 KB, text/plain)
2012-09-14 16:02 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-09-14 16:02:55 UTC
This bug was originally marked as duplicate of bug 160762, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.2 (Build 201207171143)
VM: Java HotSpot(TM) Client VM, 20.9-b04, Java(TM) SE Runtime Environment, 1.6.0_34-b04
OS: Windows 7

Stacktrace: 
java.lang.IllegalArgumentException: URI has an authority component
   at java.io.File.<init>(File.java:0)
   at org.netbeans.modules.php.dbgp.URIMapper$1.toSourceFile(URIMapper.java:168)
   at org.netbeans.modules.php.dbgp.URIMapper$MultiMapper.toSourceFile(URIMapper.java:327)
   at org.netbeans.modules.php.dbgp.SessionId.toSourceFile(SessionId.java:141)
   at org.netbeans.modules.php.dbgp.breakpoints.Utils.getDataObjectByRemote(Utils.java:216)
   at org.netbeans.modules.php.dbgp.breakpoints.Utils$LineFactory.getLine(Utils.java:186)
Comment 1 Exceptions Reporter 2012-09-14 16:02:59 UTC
Created attachment 124387 [details]
stacktrace
Comment 2 Ondrej Brejla 2012-09-17 09:22:31 UTC
Fixed in web-main #c0389613449e
Comment 3 Quality Engineering 2012-09-18 02:10:51 UTC
Integrated into 'main-golden', will be available in build *201209180001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/c0389613449e
User: Ondrej Brejla <obrejla@netbeans.org>
Log: #218393 - IllegalArgumentException: URI has an authority component


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo