Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 218200 - Code completion doesn't work on remote server, when using ip
Code completion doesn't work on remote server, when using ip
Status: RESOLVED DUPLICATE of bug 216120
Product: php
Classification: Unclassified
Component: Project
7.2
PC Windows 7
: P3 (vote)
: 7.3
Assigned To: Tomas Mysik
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 10:28 UTC by xrorox
Modified: 2012-10-11 12:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xrorox 2012-09-12 10:28:41 UTC
Hi,


Using \\192.168.xx.xx\www\my_project as source folder. Navigator works, but code completion doesn't work. Even when methods are declared in the file, you try to invoke them.


But it works with the server name, that unfortunately i can't use on this computer.

Workaround : copy in local, set local sources as your project, and tell nebeans to copy sources on your linux server.


My current computer is a windows 7 running netbean 7.2. The remote web server is a debian-like. I'm forced to use ip, cause of a problem with my windows. 

Using the ip name, i can access files, change hem, the function navigator can access them. But code completion don't work.

Still, it works once i get a local copy as my project and tell netbeans to synchronise this on the remote server. Does not work(code completion) the other way.
Comment 1 Ondrej Brejla 2012-09-12 11:09:05 UTC
Reassigning.
Comment 2 Tomas Mysik 2012-09-13 03:41:06 UTC
Might be related to issue #216120 (or duplicate). Will have a look at it.
Comment 3 xrorox 2012-09-13 07:51:29 UTC
It may be in the same component, but i don't have exactly the same problem. My errors is only on \\ip\folder, i have collegues, using netbeans 7.2 working on the exact same projects with the servername, and their code completion is working.


I don't know where the old logs are stored. If i remember well, there was some warnings about URLs. The problem is clearly related to the folder path i gave to netbeans. 

The indexing was at least running. Taking something like 60 sec.
Comment 4 Tomas Mysik 2012-10-11 12:33:01 UTC
Duplicate of #216120. Please reopen if the fix does not work for you.

Thanks.

*** This bug has been marked as a duplicate of bug 216120 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo