Bug 218159 - *Faces, Struts, Spring MVC and JSF are activated unwittingly after restart
*Faces, Struts, Spring MVC and JSF are activated unwittingly after restart
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Module System
7.3
All All
: P3 with 1 vote (vote)
: 8.0
Assigned To: Jaroslav Tulach
issues@platform
:
: 226500 226501 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 20:46 UTC by Petr Jiricka
Modified: 2013-11-20 09:27 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2012-09-11 20:46:18 UTC
1. Make sure Java EE modules are activated
2. Go to Tools -> Plugins, Installed tab, and check Show Details
3. Deactivate all the plugins in the Java Web and EE category except Java EE Base
4. Restart the IDE when prompted
5. Go to Tools -> Plugins, Installed tab again and check Show Details

=> You see that some more plugins in Java Web and EE category are activated, not just Java EE Base.
Comment 1 Jiri Rechtacek 2012-09-12 12:47:32 UTC
Reproduced. I guess it's caused by J2EE Base recommends "web.project.framework" token which ICE Faces, JSF, Prime Faces, ... provides. One of possible fix is ignore recommends<->provides relation in deactivating/uninstalling process.
Comment 2 Jiri Rechtacek 2012-09-12 12:55:11 UTC
Partly related to issue 202757.
Comment 3 Jiri Rechtacek 2012-09-12 13:31:19 UTC
The problem is not in handling recommends<->provides in AU but switching-on in Module System/FoD - dup of issue 215972.

*** This bug has been marked as a duplicate of bug 215972 ***
Comment 4 Tomas Mysik 2012-11-08 07:30:43 UTC
Please evaluate this issue again, fix of the issue #215972 is only in Hudson and PHP part.

Thanks.
Comment 5 Jaroslav Tulach 2012-11-08 09:11:56 UTC
Define "some more plugins"
Comment 6 Petr Jiricka 2012-11-08 15:00:51 UTC
Besides Java EE Base it's also:
- RichFaces
- ICEFaces
- Struts
- Spring Web MVC
- PrimeFaces
- JSF

So did you try to reproduce? If not, then you are not doing a good job evaluating this problem. And closing this as INVALID is totally unprofessional - you did not provide ANY justification for what is invalid about this problem.
Comment 7 Jaroslav Tulach 2012-11-09 13:15:43 UTC
> good job .. INVALID ... ANY justification for what is invalid 

If that is what you want to believe in, fine. The report does not explain exactly what is wrong nor it explains why the bug is in the infrastructure.


Justification is likely the same as in case of bug 215972 - the dependencies are unsound. 

Rather than accusing maintainers of infrastructure of not doing their job properly, I'd like to point out that it is your team, Petr, who's members reassign their issues to infrastructure without providing any justification for that on a general premise of "reassigning for evaluation".

As my primary job is to take care of module system the best I can, I don't feel able to waste my time evaluating every issue people ran into unless they provide explanation why the bug is in the infrastructure.
Comment 8 Petr Jiricka 2012-11-09 17:02:34 UTC
> The report does not explain exactly what is wrong

Sorry, I thought that that was obvious. The wrong thing is that the IDE allows the user to activate some combination of modules in Plugins dialog (namely: all plugins in the Java EE category are disabled except Java EE Base) and then the same combination is not honored after restart. So if the IDE plugins dialog believes that when Java EE Base is activated, other plugins like JSF must also be activated, why did is allow the user to have Java EE Base activated and JSF deactivated originally?

One remark regarding INVALID - see definition in http://wiki.netbeans.org/IssueLifeCycle:
"INVALID - error or misunderstanding on the user's side" - I don't see any user errors in the original steps 1-5, they are all valid UI actions.

> Rather than accusing maintainers of infrastructure

I am not accusing anyone, I only filed a bug report. That's not accusation.

> provide explanation why the bug is in the infrastructure

See above. The same combination of activated modules is accepted by Plugins dialog, and then not honored after restart. If this combination is invalid, then Plugins dialog should not allow it. If this combination is valid, then it should not be changed after restart by the module system.
Comment 9 Jaroslav Tulach 2012-11-14 07:21:31 UTC
Next question: Can you, Petr, also justify your assigned priority? E.g. will you delay the release until this bug is fixed?
Comment 10 Petr Jiricka 2012-11-14 09:10:00 UTC
The impact on the user is limited - we of course hope that there is no harm in having more plugins activated. Also, the workaround is to uninstall the plugins if you really don't want to be activated. The only thing is that I am not sure if this uncovers a larger problem in the module system that may possibly have additional (and more serious) consequences, so IMO it deserves to be investigated.

Feel free to downgrade to P3.
Comment 11 Jaroslav Tulach 2013-02-25 16:18:30 UTC
*** Bug 226501 has been marked as a duplicate of this bug. ***
Comment 12 Jaroslav Tulach 2013-02-25 16:19:12 UTC
*** Bug 226500 has been marked as a duplicate of this bug. ***
Comment 13 Jaroslav Tulach 2013-11-20 09:27:28 UTC
I am afraid we won't fix it for 8.0 and I am not aware of anyone wishing to spend a time on fixing this in the future.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo