Bug 218155 - LowPerformance took 6822 ms.
LowPerformance took 6822 ms.
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Compiler
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 18:02 UTC by javydreamercsw
Modified: 2012-11-14 16:18 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (37.76 KB, application/nps)
2012-09-11 18:02 UTC, javydreamercsw
Details
nps snapshot (123.46 KB, application/nps)
2012-10-23 18:12 UTC, lolo_101
Details
nps snapshot (192.60 KB, application/nps)
2012-10-25 12:12 UTC, stefan79
Details

Note You need to log in before you can comment on or make changes to this bug.
Description javydreamercsw 2012-09-11 18:02:47 UTC
This bug was originally marked as duplicate of bug 216053, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201209110001)
VM: Java HotSpot(TM) Client VM, 23.3-b01, Java(TM) SE Runtime Environment, 1.7.0_07-b11
OS: Windows 7

User Comments:
javydreamercsw: Right click on code to get menu. Maven index unpacking was going on the background.



Maximum slowness yet reported was 6822 ms, average is 6822
Comment 1 javydreamercsw 2012-09-11 18:02:54 UTC
Created attachment 124182 [details]
nps snapshot
Comment 2 Dusan Balek 2012-09-12 10:53:35 UTC
JUnitMethodRunnerProvider should not call javac parser from AWT EDT.
Comment 3 lolo_101 2012-10-23 18:12:20 UTC
Created attachment 126407 [details]
nps snapshot

saved persistence.xml file
Comment 4 stefan79 2012-10-25 12:12:12 UTC
Created attachment 126541 [details]
nps snapshot

Renaming.
Comment 5 Theofanis Oikonomou 2012-10-26 14:53:51 UTC
In none of the slowness reports can I spot any reference to JUnitMethodRunnerProvider. On the last two the probel seems to originate from CompilationController and RenameSupport. re-assigning for evaluation. Thank you
Comment 6 Milutin Kristofic 2012-10-26 15:06:17 UTC
It's in javydreamercsw snapshot:
org.netbeans.modules.junit.actions.JUnitMethodRunnerProvider.canHandle()	57.85053	3,500 ms (57.9%)	3,500 ms


The rest should go back to dusan.
Comment 7 Theofanis Oikonomou 2012-10-26 15:19:15 UTC
true. sorry I missed that. In that case regarding the javydreamercsw snapshot is a duplicate of bug 213998. re-assigning back to Dusan to handle the rest. Thanks
Comment 8 Dusan Balek 2012-10-26 16:11:50 UTC
OK - so the next is JPAProblemFinder that should not call javac parser from AWT EDT.
Comment 9 Sergey Petrov 2012-10-26 19:22:18 UTC
snapshots should be rearranged in this case, will keep only persistence related here
Comment 10 Sergey Petrov 2012-10-29 13:22:57 UTC
I'm not sure what may mean 'next is persistence' as see no reolution on other cases, but as initial report isn't related to persistence and there is only 2 out of 8 for persistence, create new issue #221024 for this 2 reports and push issue back without persistence for additional evaluation.
Comment 11 Dusan Balek 2012-11-14 16:18:56 UTC
The remaining exception report is already fixed in the current dev build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo