Bug 218011 - NoClassDefFoundError: org/openide/util/Enumerations$1RDupls
NoClassDefFoundError: org/openide/util/Enumerations$1RDupls
Status: RESOLVED DUPLICATE of bug 211962
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.2
All All
: P1 (vote)
: TBD
Assigned To: TomasKraus
issues@serverplugins
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 23:44 UTC by Exceptions Reporter
Modified: 2012-09-14 10:17 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.39 KB, text/plain)
2012-09-07 23:44 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-09-07 23:44:33 UTC
This bug was originally marked as duplicate of bug 211962, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.2 (Build 201207171143)
VM: Java HotSpot(TM) Client VM, 20.1-b02, Java(TM) SE Runtime Environment, 1.6.0_26-b03
OS: Linux

User Comments:
GUEST: I'm trying to right-click a folder in a project.

GUEST: I'm trying to right-click the file in one of my project. It won't pop out.

GUEST: es una porkeria esto

GUEST: q mierda no puedo dar clic derecho porke se totea este netbeans

GUEST: Trying to do a right-click in almost every project, web service or class

GUEST: Every time I use right click lauches the same error

GUEST: tried to right click on a folder in Files view

GUEST: I have fedora 17 with LXDE, i had problem with deploying an webservice to glassfish instance. Netbeans printed on the console, the following stack trace:
/home/kburek/Projects/Webservice/korczynska-ws/nbproject/build-impl.xml:726: 
java.lang.NoClassDefFoundError: org/openide/xml/XMLUtil$1
	at org.openide.xml.XMLUtil.write(XMLUtil.java:406)
	at org.netbeans.spi.settings.DOMConvertor.write(DOMConvertor.java:146)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModuleConverter$1.call(TargetModuleConverter.java:191)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModuleConverter$1.call(TargetModuleConverter.java:183)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModuleConverter.executeExclusively(TargetModuleConverter.java:351)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModuleConverter.writeTargetModule(TargetModuleConverter.java:183)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModule.save(TargetModule.java:271)
	at org.netbeans.modules.j2ee.deployment.impl.pr

GUEST: Just opening a project.

GUEST: Requested the details of the web.xml




Stacktrace: 
java.lang.NoClassDefFoundError: org/openide/util/Enumerations$1RDupls
   at org.openide.util.Enumerations.removeDuplicates(Enumerations.java:143)
   at org.openide.actions.FileSystemAction.createMenu(FileSystemAction.java:177)
   at org.openide.actions.FileSystemAction.createMenu(FileSystemAction.java:159)
   at org.openide.actions.FileSystemAction$Menu.<init>(FileSystemAction.java:269)
   at org.openide.actions.FileSystemAction$DelegateAction.getPopupPresenter(FileSystemAction.java:358)
   at org.openide.util.Utilities.actionsToPopup(Utilities.java:2764)
Comment 1 Exceptions Reporter 2012-09-07 23:44:36 UTC
Created attachment 124046 [details]
stacktrace
Comment 2 TomasKraus 2012-09-14 10:17:38 UTC
Unfortunately I'm still missing any information about Glassfish. There is nothing to do without knowing it's GF != 3.1.2.

*** This bug has been marked as a duplicate of bug 211962 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo