Bug 217999 - IDE may freeze when trying to cut/paste a file
IDE may freeze when trying to cut/paste a file
Status: RESOLVED DUPLICATE of bug 221279
Product: platform
Classification: Unclassified
Component: Data Systems
7.2
PC Linux
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 13:53 UTC by maxevron
Modified: 2012-11-06 11:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
ThreadDump when ide is frozen (19.40 KB, text/plain)
2012-09-16 21:59 UTC, driv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description maxevron 2012-09-07 13:53:10 UTC
Product Version = NetBeans IDE 7.2 (Build 201207171143)
Operating System = Linux version 3.2.0-29-generic running on amd64
Java; VM; Vendor = 1.7.0_03
Runtime = OpenJDK 64-Bit Server VM 22.0-b10

When trying to cut a file and to paste in a different folder via the project folders and files tree, Netbean may freeze.
Comment 1 maxevron 2012-09-07 14:03:10 UTC
Note: my projects are on a remote server, transfer is made via SSH.
Comment 2 Tomas Mysik 2012-09-10 07:00:09 UTC
We need a thread dump [1] when the IDE is frozen. Simply reopen this issue and attach it.

Thanks a lot.
[1] http://wiki.netbeans.org/GenerateThreadDump
Comment 3 driv 2012-09-16 21:59:41 UTC
Created attachment 124418 [details]
ThreadDump when ide is frozen

ThreadDump generated using jstack
Comment 4 driv 2012-09-16 22:04:30 UTC
I'm experimenting the same issue, I've attached the ThreadDump, hope it helps.

Product Version: NetBeans IDE 7.2 (Build 201207171143)
Java: 1.7.0_07; Java HotSpot(TM) 64-Bit Server VM 23.3-b01
System: Linux version 3.2.0-29-generic running on amd64; UTF-8; en_US (nb)
Comment 5 Tomas Mysik 2012-09-24 10:21:15 UTC
Reassigning to Nodes - Jardo, do you anything suspicious in the thread dump? Anything what could cause that the IDE is "frozen"? Thanks.
Comment 6 Jaroslav Tulach 2012-11-06 11:33:05 UTC

*** This bug has been marked as a duplicate of bug 221279 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo