Bug 217978 - Failing testWriteAccess
Failing testWriteAccess
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Options
7.3
PC Windows 7
: P1 (vote)
: 7.3
Assigned To: Jan Lahoda
issues@editor
: API, API_REVIEW_FAST, TEST
: 217794 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 09:13 UTC by Jiri Skrivanek
Modified: 2013-02-27 08:12 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Api change (10.66 KB, patch)
2012-09-11 12:20 UTC, Jan Lahoda
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2012-09-07 09:13:33 UTC
Please, evaluate testWriteAccess failures:

http://hudson4qe.cz.oracle.com/view/Trunk-QE/job/CV-multi-UI/615/jdk=JDK%207,label=ubuntu/testReport/org.netbeans.test.ide/IDECommitValidationTest/testWriteAccess/?

 ant -f java.kit test-qa-functional -Dtest.includes=**/IDECommitValidationTest*
Comment 1 Milutin Kristofic 2012-09-11 11:25:32 UTC
I suspect prefs.putBoolean("enable.breadcrumbs", true) at org.netbeans.modules.editor.EditorModule.restored(EditorModule.java:274)
Comment 2 Jan Lahoda 2012-09-11 12:20:26 UTC
Created attachment 124161 [details]
Api change
Comment 3 Jan Lahoda 2012-09-11 12:20:56 UTC
Please review.
Comment 4 Jan Lahoda 2012-09-11 12:41:10 UTC
*** Bug 217794 has been marked as a duplicate of this bug. ***
Comment 5 Jaroslav Tulach 2012-09-12 12:20:20 UTC
As far as the actual API review goes - I have nothing to add.

On a general note I am surprised breadcrums talk to editor.lib2 via non-public API. I lived under the assumption editor.lib2 is an official API replacement over editor.lib and thus I'd expect the exposes enough functionality for people using editor to eliminate use of editor.lib as well as implementation dependencies.
Comment 6 Quality Engineering 2012-09-19 03:04:25 UTC
Integrated into 'main-golden', will be available in build *201209190001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/626193f7bb4e
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #217978: enable breadcrumbs through defining a default for AlwaysEnabledAction rather then by setting it enabled
Comment 7 Jan Lahoda 2012-09-19 07:58:32 UTC
Thanks for the review, integrated.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo