Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 217762 - User defined folder is not displayed in the WEB-INF directory used for facelet templates
User defined folder is not displayed in the WEB-INF directory used for facele...
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Filesystems
7.3
PC Linux
: P2 (vote)
: 7.3
Assigned To: Jaroslav Tulach
issues@platform
: USABILITY
: 217255 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 00:22 UTC by theshowmecanuck
Modified: 2012-09-19 16:58 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (916.54 KB, text/plain)
2012-09-04 00:23 UTC, theshowmecanuck
Details
Project on Disk showing web-inf in v7.1 with all sub folders correct (51.11 KB, image/png)
2012-09-04 00:37 UTC, theshowmecanuck
Details
Project on Disk missing web-inf subfolders in dev build associated with this bug (48.00 KB, image/png)
2012-09-04 00:39 UTC, theshowmecanuck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description theshowmecanuck 2012-09-04 00:22:51 UTC
This was using a project imported from an earlier version. In 7.1 I created a templates directory in the WEB-INF directory in the projects tab to store facelet templates to protect them against direct access according to good practice. However when loading the same project in this latest dev build, the directory does not appear to exist in the project, but when the project is run, the pages work; meaning the files are really there but Netbeans is not showing them. I think this is a significant bug for anyone upgrading.

I'm including screen shots of what the WEB-INF directory looks like in both version 7.1 and in this latest dev build. Also note that the directories don't even appear in the files tab.

Note that this dev version does show improvement as it actually succeeds in running this project (i.e. deploys and runs in glassfish) while base 7.2 does not per Bug 214198  (and while 7.1 has no issues with it at all). Glad to see the good work and effort.

Product Version = NetBeans IDE Dev (Build 201209020001)
Operating System = Linux version 3.2.0-29-generic (Kubuntu 12.04) running on amd64 (i7 920)
Java; VM; Vendor = 1.7.0_05
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.1-b03
Comment 1 theshowmecanuck 2012-09-04 00:23:12 UTC
Created attachment 123841 [details]
IDE log
Comment 2 theshowmecanuck 2012-09-04 00:37:05 UTC
Created attachment 123842 [details]
Project on Disk showing web-inf in v7.1 with all sub folders correct

Project was created in v7.1. In the web-inf folder a facelettemplates folder was created to hold template files. This directory of course shows up fine in 7.1. Here is a screen shot showing this as a comparison to the next screen shot (to be attached) where it does not exist in the new build.
Comment 3 theshowmecanuck 2012-09-04 00:39:30 UTC
Created attachment 123843 [details]
Project on Disk missing web-inf subfolders in dev build associated with this bug

The facelettemplates folder is missing from the web-inf folder in the IDE (they are there on the disk). The project runs, but I can't manage the project like this.
Comment 4 David Konecny 2012-09-11 20:09:04 UTC
*** Bug 217255 has been marked as a duplicate of this bug. ***
Comment 5 David Konecny 2012-09-11 20:13:37 UTC
RE. "Also note that the directories don't even appear in the files tab." - this indicates that this is NB FileSystem API issue. Web Project's "Web Pages" node is just a delegate to underlying DataFolder and does not filtering.

Btw. do you use any versioning control?
Comment 6 Jaroslav Tulach 2012-09-19 16:58:18 UTC
Steps to reproduce?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo