Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 217725 - NullPointerException at org.netbeans.modules.autoupdate.ui.SettingsTableModel.getRowCount
NullPointerException at org.netbeans.modules.autoupdate.ui.SettingsTableModel...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Plugin Manager
7.2
All All
: P3 (vote)
: 7.2.1
Assigned To: Jiri Rechtacek
au-issues
EXCEPTIONS_REPORT, 72patch2-verified
:
: 215848 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 08:47 UTC by marco_bresciani
Modified: 2012-10-11 12:53 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.14 KB, text/plain)
2012-09-03 08:47 UTC, marco_bresciani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marco_bresciani 2012-09-03 08:47:35 UTC
Build: NetBeans IDE 7.2 (Build 201207171143)
VM: Java HotSpot(TM) Client VM, 20.5-b03, Java(TM) SE Runtime Environment, 1.6.0_30-b12
OS: Windows 7

Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.autoupdate.ui.SettingsTableModel.getRowCount(SettingsTableModel.java:166)
   at javax.swing.JTable.getRowCount(JTable.java:2631)
   at javax.swing.plaf.basic.BasicTableUI.createTableSize(BasicTableUI.java:1646)
   at javax.swing.plaf.basic.BasicTableUI.getPreferredSize(BasicTableUI.java:1687)
   at javax.swing.JComponent.getPreferredSize(JComponent.java:1634)
   at javax.swing.ScrollPaneLayout.layoutContainer(ScrollPaneLayout.java:769)
Comment 1 marco_bresciani 2012-09-03 08:47:37 UTC
Created attachment 123813 [details]
stacktrace
Comment 2 Jiri Rechtacek 2012-09-06 09:00:29 UTC
http://hg.netbeans.org/core-main/rev/dd5fe08dfb4a
Comment 3 Quality Engineering 2012-09-07 02:13:17 UTC
Integrated into 'main-golden', will be available in build *201209070001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/dd5fe08dfb4a
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #217725: NPE at org.netbeans.modules.autoupdate.ui.SettingsTableModel.getRowCount
Comment 4 Jiri Rechtacek 2012-09-14 11:58:58 UTC
*** Bug 215848 has been marked as a duplicate of this bug. ***
Comment 5 Jiri Rechtacek 2012-10-03 15:29:07 UTC
http://hg.netbeans.org/releases/rev/6f342d1c880d
Comment 6 Quality Engineering 2012-10-10 14:19:19 UTC
Integrated into 'releases', will be available in build *201210100934* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/6f342d1c880d
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #217725: NPE at org.netbeans.modules.autoupdate.ui.SettingsTableModel.getRowCount
(transplanted from dd5fe08dfb4adb675dc727a85315ea9f3f6c499f)
Comment 7 Petr Cyhelsky 2012-10-11 12:53:34 UTC
verified in 7.2.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo