Bug 217555 - JavaHelp: ConfigFile and/or IndexBuilder not set
JavaHelp: ConfigFile and/or IndexBuilder not set
Status: RESOLVED FIXED
Product: usersguide
Classification: Unclassified
Component: Database
7.3
All All
: P1 (vote)
: 7.4
Assigned To: Kenneth Ganfield
issues@usersguide
EXCEPTIONS_REPORT
: NO73
: 234799 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 22:56 UTC by John Jullion-ceccarelli
Modified: 2013-08-22 13:40 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.10 KB, text/plain)
2012-08-28 22:56 UTC, John Jullion-ceccarelli
Details
stacktrace (4.10 KB, text/plain)
2013-01-23 11:01 UTC, Alexander Simon
Details
stacktrace (4.10 KB, text/plain)
2013-08-22 06:52 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Jullion-ceccarelli 2012-08-28 22:56:29 UTC
This bug was originally marked as duplicate of bug 127368, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build ODS-176-on-20120828)
VM: Java HotSpot(TM) Client VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b20
OS: Windows 7

User Comments:
GUEST: trying to open the help documentation.

johnjullion: trying to open help




Stacktrace: 
java.lang.IllegalArgumentException: view is invalid
   at javax.help.search.MergingSearchEngine.merge(MergingSearchEngine.java:91)
   at javax.help.JHelpSearchNavigator.merge(JHelpSearchNavigator.java:168)
   at javax.help.plaf.basic.BasicSearchNavigatorUI.addSubHelpSets(BasicSearchNavigatorUI.java:275)
   at javax.help.plaf.basic.BasicSearchNavigatorUI.reloadData(BasicSearchNavigatorUI.java:225)
   at javax.help.plaf.basic.BasicSearchNavigatorUI.installUI(BasicSearchNavigatorUI.java:174)
   at javax.swing.JComponent.setUI(JComponent.java:664)
Comment 1 John Jullion-ceccarelli 2012-08-28 22:56:32 UTC
Created attachment 123679 [details]
stacktrace
Comment 2 Marian Mirilovic 2012-09-13 07:54:16 UTC

*** This bug has been marked as a duplicate of bug 127368 ***
Comment 3 Jaroslav Havlin 2012-09-13 11:28:16 UTC
This is probably not duplicate of bug 127368.
Problem seems to be caused by configuration of builder.

Hudson console:

 [repeat] Note: Indexing 4 HTML files in
                /space/hudson/jobs/ODS/workspace/dbschema/src/org/netbeans/modules/dbschema/docs 
                into org/netbeans/modules/dbschema/docs/JavaHelpSearch/
 [repeat] java.lang.Exception: ConfigFile and/or IndexBuilder not set
 [repeat] 	at com.sun.java.help.search.DefaultIndexerKit.storeToken(DefaultIndexerKit.java:145)
 [repeat] 	at com.sun.java.help.search.DefaultIndexerKit.parseIntoTokens(DefaultIndexerKit.java:106)
 [...]
 [repeat] 	at com.sun.java.help.search.Indexer.parseFile(Indexer.java:260)
 [repeat] 	at com.sun.java.help.search.Indexer.compile(Indexer.java:208)
 [repeat] 	at com.sun.java.help.search.Indexer.main(Indexer.java:76)
 [repeat] 	at org.netbeans.modules.javahelp.HelpSetRegistrationProcessor.handleProcess(
                   HelpSetRegistrationProcessor.java:168)
Comment 4 Jaroslav Havlin 2012-09-13 11:51:38 UTC
Only reproducible on branch builds from
http://konik-z2.cz.oracle.com:8080/hudson/job/ODS/
Comment 5 Jaroslav Havlin 2012-11-30 16:12:42 UTC
Could be related to bug 107775.
Comment 6 Alexander Simon 2013-01-23 11:01:42 UTC
Created attachment 130522 [details]
stacktrace
Comment 7 Jiri Skrivanek 2013-08-22 06:52:05 UTC
Created attachment 139038 [details]
stacktrace

To reproduce:
- run IDE from zip distribution (ergonomics enabled)
- create java project
- open main menu Help|Help Contents
Comment 8 Jiri Skrivanek 2013-08-22 07:01:56 UTC
Now it is not possible to open help which also blocks automated tests.

Product Version: NetBeans IDE Dev (Build 201308212300)
Java: 1.7.0_40; Java HotSpot(TM) 64-Bit Server VM 24.0-b55
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b40
Comment 9 Jaroslav Havlin 2013-08-22 08:28:37 UTC
The older reports are probably related to system configuration, see bug 107775.

The current problem is caused by removing help files in dbschema:
http://hg.netbeans.org/core-main/rev/4a957f5c4a70

I've removed the rest of HelpSet files:
http://hg.netbeans.org/core-main/rev/a790bd35c97f

The helpset is not completely unregistered, including mapping of help IDs
and items in TOC. Maybe we will have to update mappings and TOC of the
helpset where the topic was moved into.

Ken, can you please check it? Thanks.
Comment 10 Jaroslav Havlin 2013-08-22 13:40:47 UTC
*** Bug 234799 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo