Bug 217226 - org.osgi.framework.BundleException: The bundle "org.springframework.web_3.1.1.RELEASE [47]" could not be resolved. Reason: Missing Constraint: Import-Package: org.aopalliance.aop; version="[1.0.0,2.0.
org.osgi.framework.BundleException: The bundle "org.springframework.web_3.1.1...
Status: VERIFIED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
7.3
All All
: P2 (vote)
: 7.3
Assigned To: Tomas Stupka
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 12:53 UTC by Jiri Skrivanek
Modified: 2012-11-30 12:31 UTC (History)
20 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.07 KB, text/plain)
2012-08-22 12:54 UTC, Jiri Skrivanek
Details
stacktrace (2.09 KB, text/plain)
2012-09-25 02:14 UTC, Jesse Glick
Details
stacktrace (2.08 KB, text/plain)
2012-09-25 17:14 UTC, sunbiz
Details
stacktrace (2.07 KB, text/plain)
2012-10-02 09:05 UTC, Petr Cyhelsky
Details
stacktrace (2.06 KB, text/plain)
2012-10-20 13:35 UTC, marco76
Details
stacktrace (2.05 KB, text/plain)
2012-11-01 14:14 UTC, Tomas Danek
Details
stacktrace (2.09 KB, text/plain)
2012-11-01 16:59 UTC, Marian Mirilovic
Details
stacktrace (2.08 KB, text/plain)
2012-11-02 14:59 UTC, Tomas Danek
Details
stacktrace (2.10 KB, text/plain)
2012-11-02 15:47 UTC, Tomas Danek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2012-08-22 12:53:57 UTC
This issue was reported manually by jskrivanek.
It already has 2 duplicates 


Build: NetBeans IDE Dev (Build 20120821-a6df67629e37)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.2-b09, Java(TM) SE Runtime Environment, 1.7.0_06-b24
OS: Windows 7

User Comments:
jskrivanek: To reproduce:
- open jellytools.java project in NetBeans
- open "Functional Test Packages|Examples|EmptyTest.java"
- run test (Ctrl+F6)

jskrivanek: Running UI test from IDE.




Stacktrace: 
org.osgi.framework.BundleException: The bundle "org.springframework.web_3.1.1.RELEASE [47]" could not be resolved. Reason: Missing Constraint: Import-Package: org.aopalliance.aop; version="[1.0.0,2.0.0)"
   at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1327)
   at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1311)
   at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
   at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:389)
   at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1131)
   at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
Comment 1 Jiri Skrivanek 2012-08-22 12:54:00 UTC
Created attachment 123402 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-08-22 15:03:15 UTC
Use NbModuleSuite.Configuration.honorAutoloadEager as shown in patch http://bugzilla-attachments-210618.netbeans.org/bugzilla/attachment.cgi?id=123408
or convince connected developers to fix dependency of this bundle.
Comment 3 Jiri Skrivanek 2012-08-23 07:29:10 UTC
I really don't want to edit every single test to add honorAutoloadEager(true) to NbModuleSuite configuration. Please, remove this bundle from IDE if it is not usable or catch this exception somewhere.
Comment 4 Jaroslav Tulach 2012-08-23 08:16:19 UTC
Your current test configuration (without honorAutoloadEager) differs from the standard netbeans.exe configuration. Should your goal be to mimic the standard configuration in the test run as closely as possible, then you find a way to modify your tests to include honorAutoloadEager(true).

Btw. is not there a protected static factory method in JellyTestCase that majority of test runs is using? In such case it would be enough to modify that method.
Comment 5 Jiri Skrivanek 2012-08-23 09:08:41 UTC
If standard netbeans.exe configuration corresponds to honorAutoloadEager(true) than it should be default value of NbModuleSuite.Configuration. Why not to change it there?
JellyTestCase has some utility method but in most cases we use directly NbModuleSuite.Configuration because we aggregate tests into suites (e.g. JellytoolsJavaSuite.java).
Comment 6 Exceptions Reporter 2012-09-10 08:53:15 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=191741
Comment 7 Quality Engineering 2012-09-13 02:10:51 UTC
Integrated into 'main-golden', will be available in build *201209130001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/0cad7694c9e0
User: Jiri Skrivanek <jskrivanek@netbeans.org>
Log: #217226 - Added honorAutoloadEager(true) to JellyTestCase.createModuleTest and to new method JellyTestCase.emptyConfiguration(). It should satisfy that IDE is run as close as possible to execution from command line.
Comment 8 Jesse Glick 2012-09-25 02:14:10 UTC
Created attachment 124835 [details]
stacktrace

Started nb72 in fresh userdir.
Comment 9 sunbiz 2012-09-25 17:14:11 UTC
Created attachment 124897 [details]
stacktrace

got this error after uninstalling the JIRA plugin
Comment 10 Petr Cyhelsky 2012-10-02 09:05:15 UTC
Created attachment 125196 [details]
stacktrace
Comment 11 marco76 2012-10-20 13:35:20 UTC
Created attachment 126237 [details]
stacktrace

I was doing the review of this tutorial:
http://platform.netbeans.org/tutorials/nbm-java-hint.html
The error appearead at the point 6: Switch back to the Projects window, right-click the module, and choose Run.
Comment 12 Tomas Danek 2012-11-01 14:14:06 UTC
Created attachment 126921 [details]
stacktrace

uninstalled "User installed plugins" - i think CVS, JIRA, HTML 5 whatever
Comment 13 Marian Mirilovic 2012-11-01 16:59:06 UTC
Created attachment 126934 [details]
stacktrace
Comment 14 Marian Mirilovic 2012-11-01 18:22:01 UTC
100 % reproducible for upgrade from NB 7.3 Beta to Beta 2
Comment 15 Tomas Danek 2012-11-02 14:59:07 UTC
Created attachment 127024 [details]
stacktrace

just unistalled JIRA from beta2 build
Comment 16 Tomas Danek 2012-11-02 15:47:06 UTC
Created attachment 127029 [details]
stacktrace

beta->beta2 (after upgrade on start)
Comment 17 Tomas Danek 2012-11-07 09:27:09 UTC
removing 73beta2-stopper, since majority of reports were not relevant to this case and are separated now.
Comment 18 Tomas Stupka 2012-11-07 09:32:11 UTC
almost all reports from this issue are unrelated to the orignal report by jskrivanek. even if the stacktrace is the same, the error msg is different and indicates a different dependency problem. 

the only reason for this one is the missing org.aopalliance.aop library

filed a new issue #221608 to cover all the other reports
Comment 19 Tomas Stupka 2012-11-27 09:17:03 UTC
should be gone since #a96c8a09ce3d


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo