Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 21686 - Make boolean-toggling easier by using checkboxes instead of comboboxes
Make boolean-toggling easier by using checkboxes instead of comboboxes
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Property Editors
3.x
All All
: P2 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
: UI
: 22832 26576 (view as bug list)
Depends on: 31896
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-18 22:17 UTC by Torbjorn Norbye
Modified: 2008-12-22 19:56 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Torbjorn Norbye 2002-03-18 22:17:11 UTC
See the thread "Can we make boolean-toggling easier?" on nbui
for details.

In particular, I'd like the Setup Wizard to use check boxes such
that I can easily (with a single click) toggle a module or module
category's state. (When the value is [boolean], show the check box
editor in a different shade.)

But it would be nice if this was done globally to all boolean
property editors.
Comment 1 Jaroslav Tulach 2002-03-19 08:33:54 UTC
I believe this could be handled by better BooleanProperty editor.
Comment 2 Torbjorn Norbye 2002-05-31 23:51:27 UTC
Any plans to fix this? I'm writing a new module which could really
use this feature.
Comment 3 Jan Jancura 2002-06-04 09:28:11 UTC
*** Issue 22832 has been marked as a duplicate of this issue. ***
Comment 4 Marek Grummich 2002-07-22 09:18:11 UTC
Target milestone was changed from '3.4' to TBD.
Comment 5 akemr 2002-08-01 10:51:07 UTC
Reassign to Jano to make UI decision.
Comment 6 akemr 2002-08-19 08:17:04 UTC
*** Issue 26576 has been marked as a duplicate of this issue. ***
Comment 7 _ ttran 2002-08-19 15:32:43 UTC
URL to the diccussion started on nbui by Tor in March/2002

[nbui] Can we make boolean-toggling easier?
http://www.netbeans.org/servlets/ReadMsg?msgId=281730&listName=nbui
http://www.netbeans.org/servlets/BrowseList?listName=nbui&by=thread&from=10711

I would like to it in NB 4.0
Comment 8 Marian Mirilovic 2002-12-06 17:09:35 UTC
reassigne to Tim, new owner of property editors.
Comment 9 Marian Mirilovic 2003-01-17 14:31:00 UTC
Tim , I know you plan this type of changes in property sheets, is it
possible provide it in the Tree Table View ?
Comment 10 _ tboudreau 2003-01-17 15:52:50 UTC
My guess is TreeTableView uses PropertyPanel, so eventually it will
be, but converting PropertyPanel will happen after the property
sheet reimplementation is done.  The current property sheet and
PropertyPanel share use of SheetButton for the items.  Right now
the new implementation on the branch has gotten rid of SheetButton,
but PropertyPanel is still using it.  Eventually they will again
share the same infrastructure.
Comment 11 _ tboudreau 2003-06-03 15:09:21 UTC
Changing dependency to post-PropertySheet PropertyPanel 
rewrite.  Note that the HIE folks are pushing very hard for
using radio buttons instead of a checkbox, so this issue
may end up as WONTFIX.
Comment 12 _ tboudreau 2003-07-16 20:23:26 UTC
FWIW, this is partially fixed - the new property sheet is
integrated.
Comment 13 _ tboudreau 2003-12-09 09:37:14 UTC
Property panel rewrite branch merged.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo