Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 216517 - allow partial "deploy on save" only on changes web pages, not on changed java-files
allow partial "deploy on save" only on changes web pages, not on changed java...
Status: RESOLVED DUPLICATE of bug 218345
Product: javaee
Classification: Unclassified
Component: Maven
7.2
PC Windows 7
: P3 (vote)
: 7.4
Assigned To: Martin Janicek
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 09:44 UTC by mart_l
Modified: 2013-09-02 08:39 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mart_l 2012-08-08 09:44:55 UTC
While in-place debugging web-application - does not work "deploy on save" when changed xhtml-file is saved, unless "compile on save" is checked. However when checked "compile on save", then after changed java file is saved, the maven plugin automaticaly redeploys a restarts server - not even option to stop redeployment and server restart process.

I miss possibility to partialy redeploy only changed xhtml files and not automaticaly redeploy changed java classes. For changed java classes i use "apply code changes".
Comment 1 Martin Janicek 2012-08-08 09:48:22 UTC
Sounds like a nice enhancement, but most probably there won't be enough of time to do that for the NetBeans 7.3, because there are other things I need to work on at the moment. Setting TM = Next
Comment 2 Martin Janicek 2013-09-02 08:39:34 UTC

*** This bug has been marked as a duplicate of bug 218345 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo