Bug 216462 - Javascript Parameter color value is overridden by Identifier value
Javascript Parameter color value is overridden by Identifier value
Status: RESOLVED DUPLICATE of bug 218656
Product: javascript
Classification: Unclassified
Component: Editor
7.2
PC Windows 7
: P3 with 1 vote (vote)
: 7.3
Assigned To: Martin Fousek
issues@javascript
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 01:03 UTC by thegame
Modified: 2012-09-24 06:04 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
The parameter color is changed to orange, but both the preview window and the editor shows it as blue, which is the color of Identifiers (59.50 KB, image/png)
2012-08-07 01:03 UTC, thegame
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thegame 2012-08-07 01:03:36 UTC
Created attachment 122815 [details]
The parameter color is changed to orange, but both the preview window and the editor shows it as blue, which is the color of Identifiers

In any color scheme, changing the color of a function parameter/argument in Netbeans 7.2 is negated. It seems to be using the color value of the Identifier.

See screenshot.
Comment 1 Martin Fousek 2012-09-24 06:04:23 UTC
Coloring troubles should be fixed due to issue #218656. BTW, in the new JS editor is not supported coloring of parameters for now (as it never probably worked before), but feel free to raise a new enhancement for improving coloring categories (and adding parameters there).

*** This bug has been marked as a duplicate of bug 218656 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo