Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 216364 - Weird gray column in editor
Weird gray column in editor
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
8.1
PC All
: P3 (vote)
: 8.1
Assigned To: Svata Dedic
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 12:32 UTC by Vladimir Riha
Modified: 2015-08-05 17:17 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screemshot (77.80 KB, image/png)
2012-08-03 12:32 UTC, Vladimir Riha
Details
Editor window with blue-gray bar (599.09 KB, image/png)
2015-05-21 18:02 UTC, mdeggersbeans
Details
patch partially reverting svata's changes (1.18 KB, patch)
2015-07-31 08:34 UTC, Ondrej Vrabec
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2012-08-03 12:32:49 UTC
Created attachment 122716 [details]
screemshot

Please look at the screenshot, there is a strange gray column. I don't know, if it is only in javascript files or not.

It is reproducible with following file:
http://code.jquery.com/jquery-1.7.2.js


Product Version: NetBeans IDE Dev (Build 201208030001)
Java: 1.7.0_06-ea; Java HotSpot(TM) Client VM 23.2-b09
System: Linux version 3.0.0-23-generic running on i386; UTF-8; en_US (nb)
Comment 1 mdeggersbeans 2015-05-21 18:02:35 UTC
Created attachment 153796 [details]
Editor window with blue-gray bar
Comment 2 mdeggersbeans 2015-05-21 18:09:13 UTC
This now appears in the nightly builds.

OS:       Windows 7 Home Premium 64 bit
JDK:      1.8.0_45-b14
Netbeans: 201505210001
LAF:      Nimbus

This does not appear in Netbeans 8.0.2 using the same environment. This did not appear on earlier versions of the nightly builds. Unfortunately, I have not archived earlier versions of the nightly builds.

The nightly build was installed in a completely clean environment.
Comment 3 Ondrej Vrabec 2015-07-31 08:32:55 UTC
Svato, see the second screenshot, it's with Nimbus L&F, is caused by a wrong background of diff sidebar and is caused by your changes in #f55ab8d5b862. If i revert the commit back or apply the following patch (that partially reverts your changes) it works again. Could you please take a look, seems that "Implemented common coloring for sidebar backround" does not work properly on Nimbus.
Comment 4 Ondrej Vrabec 2015-07-31 08:34:15 UTC
Created attachment 155072 [details]
patch partially reverting svata's changes
Comment 5 Vladimir Riha 2015-07-31 08:59:07 UTC
I've seen it couple of times in Dark Metal as well (I'm importing my color schemes and sometimes this area had a wrong color)
Comment 6 Svata Dedic 2015-08-03 14:29:58 UTC
Should be fixed by jet-main ... removing the changes and yet more since the common sidebar implementation handles the bkg color changes already. jet-main#51c78b5e7be5
Comment 7 mdeggersbeans 2015-08-04 16:19:07 UTC
(In reply to Svata Dedic from comment #6)
> Should be fixed by jet-main ... removing the changes and yet more since the
> common sidebar implementation handles the bkg color changes already.
> jet-main#51c78b5e7be5

Has this made it into the nightly builds yet?

I'm still seeing the issue in the following:

Product Version: NetBeans IDE Dev (Build 201508040002)
Java: 1.8.0_51; Java HotSpot(TM) 64-Bit Server VM 25.51-b03
Runtime: Java(TM) SE Runtime Environment 1.8.0_51-b16
System: Windows 7 version 6.1 running on amd64; UTF-8; en_US (nb)
User directory: C:\Users\mdeggers\AppData\Roaming\NetBeans\dev
Cache directory: C:\Users\mdeggers\AppData\Local\NetBeans\Cache\dev
Comment 8 Quality Engineering 2015-08-05 01:20:33 UTC
Integrated into 'main-silver', will be available in build *201508050002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/51c78b5e7be5
User: Svata Dedic <sdedic@netbeans.org>
Log: #216364: fixed color updates in sidebar
Comment 9 mdeggersbeans 2015-08-05 17:17:46 UTC
Confirmed as fixed in my environment.

Product Version: NetBeans IDE Dev (Build 201508050002)
Java: 1.8.0_51; Java HotSpot(TM) 64-Bit Server VM 25.51-b03
Runtime: Java(TM) SE Runtime Environment 1.8.0_51-b16
System: Windows 7 version 6.1 running on amd64; UTF-8; en_US (nb)
User directory: C:\Users\mdeggers\AppData\Roaming\NetBeans\dev
Cache directory: C:\Users\mdeggers\AppData\Local\NetBeans\Cache\dev

Thanks for tracking this down and the great work!

/mde/


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo