Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 216218 - "Run" opens the wrong web component in the browser for Maven-based JavaEE6 EAR project
"Run" opens the wrong web component in the browser for Maven-based JavaEE6 EA...
Status: RESOLVED DUPLICATE of bug 215454
Product: javaee
Classification: Unclassified
Component: Maven
7.2
Macintosh Mac OS X
: P3 (vote)
: TBD
Assigned To: Martin Janicek
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 19:34 UTC by big_al
Modified: 2012-08-01 07:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description big_al 2012-07-31 19:34:36 UTC
How to reproduce:

1. Create Maven-based JavaEE6 EAR project
2. Open the Properties for the WAR project and change the context path to "/somethingelse"
3. Clean and build the project
4. Run the EAR project

Observed:

The browser opens http://localhost:8080/nameofwar-!.0-SNAPSHOT

Expected

The browser should open http://localhost:8080/somethingelse  (as specified in step 2).


Note, it works fine if the project is a Maven-Based JavaEE6 WAR project.
Comment 1 Jiri Skrivanek 2012-08-01 07:35:22 UTC

*** This bug has been marked as a duplicate of bug 215454 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo