Bug 21614 - caret (text cursor) in editor turns invisible
caret (text cursor) in editor turns invisible
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows ME/2000
: P3 (vote)
: 3.x
Assigned To: Peter Zavadsky
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-15 08:49 UTC by Paul Ronan
Modified: 2008-12-23 14:23 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Ronan 2002-03-15 08:49:33 UTC
This occurred in 3.2 and 3.3.1, think it occurs when switching between views or 
alt-tabbing between different ms window applications. Cursor becomes invisible 
but keystrokes are fine.
Comment 1 Martin 2002-03-18 14:43:31 UTC
JDK 1.3.1 (and 1.3.1_02)
NetBeans 3.3.1
NT 4 SP 6

It always occurs when after running a failing JUnit test I double 
click a hot-link in the stack trace in the output window which goes 
to the correct line in my source file but the caret disappears.  The 
only way I can get the caret back is to switch to another windows app 
then back to NetBeans.

It occurs at other times too but the above is easily duplicatable.

One issue could be that I have no 'Running' workspace (I don't know 
why) so there is no workspace change between test and edit.
Comment 2 Martin 2002-03-18 14:50:08 UTC
Is this related to issue 13389?
Comment 3 _ ttran 2002-03-25 06:56:05 UTC
this is the case of missing FOCUS_GAINED/FOCUS_LOST events.  I recall
in the past the editor module had a workaround for it.  But Mila has
asked to remove the workaround because JDK has supposedly fixed the
bug which obviously is not true
Comment 4 Miloslav Metelka 2002-03-25 07:45:38 UTC
It was only a kind of visual workaround that allowed the caret to stay
blinking in the editor but the focus was not really there (the pressed
keystrokes did not go into the editor). I have suggested to remove it
because the workaround was misleading by giving the feeling that 
everything works fine although it really didn't.
Comment 5 arittner 2002-05-28 22:43:41 UTC
I can confirm this issue under W2K with JUnit.
But on any testcase (failed and ok).

Workaround: 
Focus a native windows program with a textfield. Switch 
back to Netbeans: the caret becomes visible.
Comment 6 Peter Hunter 2002-07-01 10:49:28 UTC
This issue causes problems on Mac OS X too. Should I file a seperate
bug for that?
Comment 7 Peter Zavadsky 2002-07-01 12:03:13 UTC
Peter,
If the test case is same, it's enough to mention it here as you did.
Otherwise please submit separate issue.
Comment 8 Marek Grummich 2002-07-22 08:40:36 UTC
Target milestone was changed from '3.4' to TBD.
Comment 9 Marek Grummich 2002-07-22 08:43:35 UTC
Target milestone was changed from '3.4' to TBD.
Comment 10 Marek Grummich 2002-07-22 08:47:16 UTC
Target milestone was changed from '3.4' to TBD.
Comment 11 Marek Grummich 2002-07-22 08:54:40 UTC
Target milestone was changed from '3.4' to TBD.
Comment 12 Marek Grummich 2002-07-22 08:57:59 UTC
Target milestone was changed from '3.4' to TBD.
Comment 13 Marek Grummich 2002-07-22 09:02:32 UTC
Target milestone was changed from '3.4' to TBD.
Comment 14 Peter Zavadsky 2002-07-22 14:04:54 UTC
Well, there is nothing new to say here. 
Since we don't have a reproducible case it needs to be
revised/investigated from the code perspective.
Comment 15 Miloslav Metelka 2002-07-25 09:48:49 UTC
There is an issue 25996 that appears to be related to this one.
Comment 16 Marian Mirilovic 2002-12-06 18:19:05 UTC
reassign to Tim, new owner of AWT/Swing
Comment 17 _ tboudreau 2003-03-03 17:29:58 UTC
Reassigning to window system (spoke with Peter Z. about this last
week).
Comment 18 Robbie Baldock 2003-05-19 16:49:57 UTC
I've seen this a lot in the last few versions of NetBeans -
 but it seems to have actually got worse in 3.5 RC 1.  

I used to be able to restore the cursor in the editor 
either by clicking in a different window and then back on 
the editor or by minimising and restoring the IDE.  But 
there have been a couple of instances recently where I've 
had to restart the IDE to get the cursor back!  I run 
NetBeans in Windows 2000.  

By the way, I don't recall seeing the problem at home 
where I use XP.


Robbie

Comment 19 mslama 2003-06-09 14:19:35 UTC
Is here anybody who is able to reproduce it? What JDK? I could prepare
patch to investigate where focus is. If focus is in editor pane
(inside editor TopComponent) then it is issue for editor module (or
owner of given TopComponent).
Comment 20 Marian Mirilovic 2003-11-26 12:54:59 UTC
Because Window System v1 will not be supported from now by our team, all old
winsys issues (now "core/window system v1" issues) are going to be closed as
WONTFIX. 

Changes in API which emerged both from UI spec 
and problems with adjusting to the older API are described in the document
http://core.netbeans.org/windowsystem/changes.html.
 It shows also recommends how the client code should be adjusted to the new
window system.

If you think this issue apply also to the new winsys then change the
subcomponent (to "core/window system") and REOPEN it.
Comment 21 Marian Mirilovic 2004-02-27 14:12:37 UTC
issue doesn't apply to new window system - verified
Comment 22 Quality Engineering 2008-12-23 14:23:02 UTC
This issue had *1 votes* before move to platform component


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo