Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 216127 - Console window does not allow left to right scrolling
Console window does not allow left to right scrolling
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Output Window
7.2
Macintosh (x86) Mac OS X
: P3 (vote)
: 8.0
Assigned To: Jaroslav Havlin
issues@platform
:
: 234591 239844 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 10:51 UTC by randahl
Modified: 2014-01-09 14:49 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description randahl 2012-07-30 10:51:48 UTC
Using the trackpad on my Mac I am able to scroll both vertically and horizontally in most of NetBeans. However, in the console window, both vertical and horizontal to-finger scrolling on the trackpad makes the window scroll vertically.

The same goes for my two-axis scrolling enabled logitech mouse: In the console window, I only get vertical scrolling, no matter which way I am actually scrolling.
Comment 1 Petr Somol 2012-07-30 15:25:16 UTC
Jarda, please evaluate whether this is within your scope..
Comment 2 Jaroslav Havlin 2013-08-22 11:30:08 UTC
*** Bug 234591 has been marked as a duplicate of this bug. ***
Comment 3 Jaroslav Havlin 2013-10-11 14:58:37 UTC
http://hg.netbeans.org/core-main/rev/756b4c3a021e
It should work better now, at least on Mac. Please verify.
Thank you for reporting.
Comment 4 Tomas Stupka 2013-10-11 16:21:00 UTC
works for me on mac
Comment 5 Quality Engineering 2013-10-12 03:59:56 UTC
Integrated into 'main-silver', will be available in build *201310120001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/756b4c3a021e
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #216127: Output Window does not allow left to right scrolling
Comment 6 Jaroslav Havlin 2014-01-09 14:48:00 UTC
Corrected fix: http://hg.netbeans.org/core-main/rev/52a7ce8c239e
Comment 7 Jaroslav Havlin 2014-01-09 14:49:41 UTC
*** Bug 239844 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo