Bug 216120 - 7.2 no longer supports UNC paths
7.2 no longer supports UNC paths
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Project
7.3
PC Windows 7
: P3 (vote)
: 7.3
Assigned To: Tomas Mysik
issues@php
EXCEPTIONS_REPORT
:
: 218200 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 08:01 UTC by kAlvaro
Modified: 2012-10-22 06:49 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.50 KB, text/plain)
2012-07-30 08:01 UTC, kAlvaro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kAlvaro 2012-07-30 08:01:05 UTC
Build: NetBeans IDE Dev (Build 201207300002)
VM: Java HotSpot(TM) Client VM, 20.8-b03, Java(TM) SE Runtime Environment, 1.6.0_33-b03
OS: Windows XP

User Comments:
kAlvaro: Steps to reproduce:

1. Create a project that points to some (PHP) code in a UNC path, e.g.: \\server\share\foo
2. Open the project and let background scanning finish.
3. Try any feature related to code intelligence, e.g. "Go to Type"

You only get matches/completions/whatever from ""%PROGRAMFILES%\NetBeans 7.2\php\phpstubs". Code in user source files is ignored.

In development releases you also get an exception:
    IllegalArgumentException: URI has an authority component

In previous releases until 7.1.2 code intelligence worked fine on UNC paths (only debugging failed). This regression was introduced in 7.2.




Stacktrace: 
java.lang.IllegalArgumentException: URI has an authority component
   at java.io.File.<init>(File.java:0)
   at org.netbeans.modules.php.project.classpath.SourcePathImplementation$FilteringPathResource.includes(SourcePathImplementation.java:219)
   at org.netbeans.api.java.classpath.ClassPath.contains(ClassPath.java:562)
   at org.netbeans.modules.php.project.api.PhpSourcePath.getFileTypeFromClassPath(PhpSourcePath.java:200)
   at org.netbeans.modules.php.project.api.PhpSourcePath.getFileType(PhpSourcePath.java:105)
   at org.netbeans.modules.php.editor.index.PHPIndexer.index(PHPIndexer.java:211)
Comment 1 kAlvaro 2012-07-30 08:01:07 UTC
Created attachment 122519 [details]
stacktrace
Comment 2 Tomas Mysik 2012-08-09 05:23:44 UTC
@vriha: Láďo, can you please try to reproduce? Thanks.
Comment 3 Vladimir Riha 2012-08-09 14:59:32 UTC
Reproducible in 7.2 and trunk, but I didn't get any exception. I also find minor issue #216614. Just to be thorough, if the network disk is mapped to some letter (F:/) and project is created using this path, it works as supposed to.


Product Version: NetBeans IDE Dev (Build 201208090001)
Java: 1.7.0_04; Java HotSpot(TM) Client VM 23.0-b21
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)
Comment 4 Tomas Mysik 2012-08-10 04:28:00 UTC
@vriha: Láďo, could you please try the same in NB 7.1? Since AFAIK there was no change in this area for PHP, the problem might be somewhere else...

Thanks.
Comment 5 Vladimir Riha 2012-08-10 06:23:35 UTC
It works fine in 7.1.2.

Also small observation, in both 7.1 & 7.2, there is proper completion for ie. 

include '';

And it offers files from UNC path
Comment 6 Tomas Mysik 2012-08-22 12:25:05 UTC
Very likely a duplicate of issue #213562. Láďo, could you please verify it?

Thanks a lot.

*** This bug has been marked as a duplicate of bug 213562 ***
Comment 7 kAlvaro 2012-08-22 20:03:49 UTC
What's the exact status of UNC support in NetBeans? Most related tickets I've been able to find, including bug #213562, are already closed, often as RESOLVED.
Comment 8 Tomas Mysik 2012-08-23 03:44:24 UTC
Since issue #213562 is resolved fixed, I guess it is fixed. But the target milestone is 7.2 so perhaps I am wrong with the duplicate... I will investigate more...
Comment 9 kAlvaro 2012-09-14 06:45:10 UTC
Not sure how to test whether it's fixed, but daily snapshots available at http://bits.netbeans.org/download/trunk/nightly/latest/ still exhibit this issue.
Comment 10 jjarolim 2012-10-05 13:10:57 UTC
2012-10-05, Netbeans IDE 7.2 (Build 201207171143):

I'm able to clearly reproduce this behaviour on windows:

Project opened via UNC path doesn't allow code completion,
same project opened via mapped network drive: code completion working.

Client: Windows 7 Professional
Server: also Windows 7 Professional
Comment 11 Tomas Mysik 2012-10-11 12:32:47 UTC
Fixed.

http://hg.netbeans.org/web-main/rev/d016bf389fac
Comment 12 Tomas Mysik 2012-10-11 12:33:01 UTC
*** Bug 218200 has been marked as a duplicate of this bug. ***
Comment 13 Quality Engineering 2012-10-12 02:06:37 UTC
Integrated into 'main-golden', will be available in build *201210120002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d016bf389fac
User: Tomas Mysik <tmysik@netbeans.org>
Log: #216120 - 7.2 no longer supports UNC paths
Comment 14 Tomas Mysik 2012-10-19 06:43:57 UTC
Láďo, this is definitely a patch candidate.

Thanks.
Comment 15 Vladimir Riha 2012-10-22 06:49:18 UTC
verified. I'm afraid it's too late for patch, nomination day was October 15(16), I'm sorry


Product Version: NetBeans IDE Dev (Build 201210220002)
Java: 1.7.0_04; Java HotSpot(TM) Client VM 23.0-b21
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo