Bug 216026 - IllegalArgumentException: Invalid org.netbeans.modules.editor.global.format for operation UPDATE
IllegalArgumentException: Invalid org.netbeans.modules.editor.global.format f...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
7.2
All All
: P3 (vote)
: 7.3
Assigned To: Jiri Rechtacek
au-issues
EXCEPTIONS_REPORT
: THREAD
: 215741 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 18:43 UTC by javydreamercsw
Modified: 2012-10-28 01:49 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.98 KB, text/plain)
2012-07-26 18:43 UTC, javydreamercsw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description javydreamercsw 2012-07-26 18:43:05 UTC
Build: NetBeans IDE 7.2 (Build 201207171143)
VM: Java HotSpot(TM) Client VM, 23.1-b03, Java(TM) SE Runtime Environment, 1.7.0_05-b05
OS: Windows 7

User Comments:
javydreamercsw: I selected the run in background check box during an update.




Stacktrace: 
java.lang.IllegalArgumentException: Invalid org.netbeans.modules.editor.global.format for operation UPDATE
   at org.netbeans.modules.autoupdate.services.OperationContainerImpl.add(OperationContainerImpl.java:115)
   at org.netbeans.modules.autoupdate.services.OperationContainerImpl.listAllWithPossibleEager(OperationContainerImpl.java:261)
   at org.netbeans.api.autoupdate.OperationContainer.listAll(OperationContainer.java:347)
   at org.netbeans.modules.autoupdate.ui.Utilities.createVisibleModulesDependecyMap(Utilities.java:362)
   at org.netbeans.modules.autoupdate.ui.Utilities.makeUpdateCategories(Utilities.java:258)
   at org.netbeans.modules.autoupdate.ui.UpdateTableModel.setUnits(UpdateTableModel.java:81)
Comment 1 javydreamercsw 2012-07-26 18:43:07 UTC
Created attachment 122426 [details]
stacktrace
Comment 2 Jiri Rechtacek 2012-10-17 15:55:27 UTC
*** Bug 215741 has been marked as a duplicate of this bug. ***
Comment 3 Jiri Rechtacek 2012-10-26 13:25:24 UTC
http://hg.netbeans.org/core-main/rev/787d71ad3910
Comment 4 Quality Engineering 2012-10-28 01:49:14 UTC
Integrated into 'main-golden', will be available in build *201210280001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/787d71ad3910
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #216026 - IAE: Invalid org.netbeans.modules.editor.global.format for operation UPDATE


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo