Bug 216013 - Provide combo box for color selection.
Provide combo box for color selection.
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Stanislav Aubrecht
issues@platform
: API, API_REVIEW_FAST
: 211598 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 15:50 UTC by Stanislav Aubrecht
Modified: 2012-08-04 02:33 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
proposed API changes (29.98 KB, patch)
2012-07-26 15:57 UTC, Stanislav Aubrecht
Details | Diff
new API class (7.97 KB, text/plain)
2012-07-27 09:11 UTC, Stanislav Aubrecht
Details
new class missing in the patch (3.82 KB, text/plain)
2012-07-27 09:11 UTC, Stanislav Aubrecht
Details
new class missing in the patch (4.66 KB, text/plain)
2012-07-27 09:12 UTC, Stanislav Aubrecht
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Aubrecht 2012-07-26 15:50:49 UTC
The IDE shows a combo box with a list of colors at several places. The current implementation has some look&feel problems and also its code is copy-pasted to several modules.

I propose providing a new public class that could be used as a combo box component to select a color.
Comment 1 Stanislav Aubrecht 2012-07-26 15:57:52 UTC
Created attachment 122412 [details]
proposed API changes
Comment 2 Stanislav Aubrecht 2012-07-27 09:11:20 UTC
Created attachment 122447 [details]
new API class
Comment 3 Stanislav Aubrecht 2012-07-27 09:11:56 UTC
Created attachment 122448 [details]
new class missing in the patch
Comment 4 Stanislav Aubrecht 2012-07-27 09:12:28 UTC
Created attachment 122449 [details]
new class missing in the patch
Comment 5 Stanislav Aubrecht 2012-07-30 13:36:44 UTC
*** Bug 211598 has been marked as a duplicate of this bug. ***
Comment 6 Stanislav Aubrecht 2012-08-02 15:11:12 UTC
If there are no objections I'll integrate the changes tomorrow.
Comment 7 Stanislav Aubrecht 2012-08-03 14:19:21 UTC
core-main 8765ef818b1a
Comment 8 Quality Engineering 2012-08-04 02:33:06 UTC
Integrated into 'main-golden', will be available in build *201208040001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/8765ef818b1a
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #216013 - Provide combo box for color selection


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo