Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 215815 - LowPerformance took 10393 ms.
LowPerformance took 10393 ms.
Status: RESOLVED DUPLICATE of bug 215159
Product: projects
Classification: Unclassified
Component: Maven
7.2
All All
: P3 (vote)
: 7.3
Assigned To: Milos Kleint
issues@projects
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 02:50 UTC by _ wadechandler
Modified: 2012-07-23 06:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (269.22 KB, application/nps)
2012-07-23 02:50 UTC, _ wadechandler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ wadechandler 2012-07-23 02:50:40 UTC
This bug was originally marked as duplicate of bug 170858, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.2 (Build nbms-and-javadoc-9336-on-20120629)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b20
OS: Linux

User Comments:
wadechandler: I opened the IDE. I have a good number of maven projects opened. The IDE initially was "Opening projects" for a long period of time. Said 200% of the CPU was used (4 core CPU). Then it went to "Background scanning" and the CPU usage has been between 50% and 160 or more. The CPU usage I'm reporting is only for NetBeans btw. Heavy IO can keep the application and computer from operating well in a user interface and user interaction context.



Maximum slowness yet reported was 10393 ms, average is 10393
Comment 1 _ wadechandler 2012-07-23 02:50:48 UTC
Created attachment 122255 [details]
nps snapshot
Comment 2 Milos Kleint 2012-07-23 06:44:26 UTC
from the symptoms described by wadechandler, it appears like the following problem:

with many maven projects around, when the heap memory starts to reach it's hard limit, soft references get de-referenced. Significant one for this issue is the one holding o.a.maven.MavenProject, the entire maven's model. Unfortunately in many cases we are just trading memory for CPU here, especially if project opening is still going on.

In 7.3 codebase (current dev builds) I've fixed issue 215159, bringing the memory requirements of the maven model down significantly. When just opening 300 glassfish projects we used to hit the memory ceiling as described in this issue, with the fix we're way below the limit and also significatly faster (no gc, no recreation of MavenProject objects)

if possible, please try with the latest dev builds.

*** This bug has been marked as a duplicate of bug 215159 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo