Bug 215753 - NoClassDefFoundError: org/openide/util/NetworkSettings
NoClassDefFoundError: org/openide/util/NetworkSettings
Status: RESOLVED DUPLICATE of bug 211962
Product: platform
Classification: Unclassified
Component: Module System
7.1
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 07:38 UTC by Exceptions Reporter
Modified: 2012-07-21 05:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.61 KB, text/plain)
2012-07-20 07:38 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-07-20 07:38:43 UTC
This bug was originally marked as duplicate of bug 196563, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.1.2 (Build 201204101705)
VM: Java HotSpot(TM) Client VM, 20.1-b02, Java(TM) SE Runtime Environment, 1.6.0_26-b03
OS: Linux

Stacktrace: 
java.lang.NoClassDefFoundError: org/openide/util/NetworkSettings
   at org.netbeans.modules.subversion.config.SvnConfigFiles.setProxy(SvnConfigFiles.java:255)
   at org.netbeans.modules.subversion.config.SvnConfigFiles.storeSvnServersSettings(SvnConfigFiles.java:221)
   at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.handle(SvnClientInvocationHandler.java:354)
   at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.invokeMethod(SvnClientInvocationHandler.java:321)
   at org.netbeans.modules.subversion.client.SvnClientInvocationHandler$2.call(SvnClientInvocationHandler.java:166)
   at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.invoke(SvnClientInvocationHandler.java:175)
Comment 1 Exceptions Reporter 2012-07-20 07:38:46 UTC
Created attachment 122208 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-07-21 05:55:52 UTC
I can see from the log that you are using some enterprise projects. Are you also using web services? We know that web services support was broken and could mess up classpath of the whole IDE. Which then resulted in strange ClassNotFoundExceptions.

*** This bug has been marked as a duplicate of bug 211962 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo