Bug 215653 - ClassNotFoundException: org.openide.util.actions.CallbackSystemAction$DelegateAction
ClassNotFoundException: org.openide.util.actions.CallbackSystemAction$Delegat...
Status: RESOLVED DUPLICATE of bug 211962
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.2
All All
: P3 (vote)
: TBD
Assigned To: Vince Kraemer
issues@serverplugins
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 18:56 UTC by Exceptions Reporter
Modified: 2012-09-07 14:11 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.63 KB, text/plain)
2012-07-17 18:56 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-07-17 18:56:43 UTC
This bug was originally marked as duplicate of bug 211962, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.2 RC1 (Build 201206272359)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b20
OS: Windows 7

User Comments:
GUEST: fix error

GUEST: em.persist(emp);
            em.getTransaction().commit();

GUEST: I just created a Web Service from WSDL.
Wsdl is correct (according to some commercial validators), and i get no error in the logs, but the menu with "test the service" action does not appear when i right-click on the webservice.

GUEST: When I trying to test the webservice in serverside.

GUEST: dfmvemeprc

GUEST: Right-Clicking in a package

GUEST: There's a big problem with the new IDE running on Windows. After you make deploy and then close the browser, the basic functionality of de IDE stops.

GUEST: java.lang.NoClassDefFoundError: org/openide/util/actions/CallbackSystemAction$DelegateAction
	at org.openide.util.actions.CallbackSystemAction.createContextAwareInstance(CallbackSystemAction.java:284)
	at org.openide.util.Utilities.actionsToPopup(Utilities.java:2762)
	at org.openide.util.Utilities.actionsToPopup(Utilities.java:2858)
	at org.openide.explorer.view.TreeView.createPopup(TreeView.java:1070)
	at org.openide.explorer.view.TreeView$PopupAdapter.showPopup(TreeView.java:1558)
	at org.openide.awt.MouseUtils$PopupMouseAdapter.maybePopup(MouseUtils.java:189)
	at org.openide.awt.MouseUtils$PopupMouseAdapter.mouseReleased(MouseUtils.java:184)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:290)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6505)
	at javax.swing.JComponent.processMouseEvent(JComponen

GUEST: After installing and downloading JUnit it hangs

SEVERE [global]
java.lang.NoClassDefFoundError: org/openide/util/actions/CallbackSystemAction$DelegateAction
	at org.openide.util.actions.CallbackSystemAction.createContextAwareInstance(CallbackSystemAction.java:284)
	at org.openide.util.Utilities.actionsToPopup(Utilities.java:2762)
	at org.openide.util.Utilities.actionsToPopup(Utilities.java:2858)
	at org.openide.explorer.view.TreeView.createPopup(TreeView.java:1070)
	at org.openide.explorer.view.TreeView$PopupAdapter.showPopup(TreeView.java:1558)
	at org.openide.awt.MouseUtils$PopupMouseAdapter.maybePopup(MouseUtils.java:189)
	at org.openide.awt.MouseUtils$PopupMouseAdapter.mouseReleased(MouseUtils.java:184)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:290)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.

GUEST: Trying to right click on Web Sevice Reference item, similar to my previos report it started to happen after upgrade of glassfish or installation of third party software




Stacktrace: 
java.lang.ClassNotFoundException: org.openide.util.actions.CallbackSystemAction$DelegateAction
   at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
   at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
   at java.security.AccessController.doPrivileged(AccessController.java:0)
   at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
   at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
Comment 1 Exceptions Reporter 2012-07-17 18:56:47 UTC
Created attachment 122118 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-08-07 14:17:42 UTC
Another one that goes to glassfish...
Comment 3 TomasKraus 2012-09-07 14:11:39 UTC
Well, those bugs will be coming with GF 3.1.2 all the time.
I'll be closing them as 211962 duplicates until someone will provide different GF version in the bug.
In this case it's 7.2 RC1 where we know 211962 exists, GF version is unknown (probably buggy 3.1.2 bundled with netbeans).

*** This bug has been marked as a duplicate of bug 211962 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo