Bug 215596 - Deadlock between NetigsoHandle and SystemClassLoader
Deadlock between NetigsoHandle and SystemClassLoader
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Netigso
7.2
PC Linux
: P3 (vote)
: 7.3
Assigned To: Jaroslav Tulach
issues@platform
: THREAD
: 222494 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 17:21 UTC by Jesse Glick
Modified: 2012-11-21 15:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (36.33 KB, text/plain)
2012-07-16 17:21 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-07-16 17:21:32 UTC
Created attachment 122069 [details]
Thread dump

Occurred in 7.2 RC1 while installing JIRA plugin via button in "Create Issue Tracker" dialog. Some (all?) required modules were installed according to status messages in main window, then IDE froze.
Comment 1 Jaroslav Tulach 2012-11-19 09:42:53 UTC
ergonomics#0af59e7fad42
Comment 2 Quality Engineering 2012-11-21 13:41:03 UTC
Integrated into 'main-golden', will be available in build *201211211016* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/0af59e7fad42
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #215596: Deadlock between NetigsoHandle and SystemClassLoader
#215596: Giving the "framework" field different lock than the rest of the other data structures here-in
Comment 3 Jaroslav Tulach 2012-11-21 15:59:55 UTC
*** Bug 222494 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo