Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 215594 - Netbeans runs maven projects through ant instead of maven exec plugin
Netbeans runs maven projects through ant instead of maven exec plugin
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
7.2
PC Windows 7
: P1 with 1 vote (vote)
: 7.4
Assigned To: Milos Kleint
issues@projects
:
Depends on:
Blocks: 180519 215575 217722
  Show dependency treegraph
 
Reported: 2012-07-16 16:15 UTC by evillive
Modified: 2013-02-21 12:34 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description evillive 2012-07-16 16:15:38 UTC
Netbeans uses ant to execute maven projects.

Steps to reproduce:
1. Run maven project via F6 or "Run" context menu
   Netbeans uses maven exec plugin

2. Stop project execution and re-run it via F6 or "Run" menu.
   Netbeans uses ant now.

There is similar issue (http://netbeans.org/bugzilla/show_bug.cgi?id=198912) that has status RESOLVED INVALID. I'm not sure if this is designed behavior, but at least, there is related issue (http://netbeans.org/bugzilla/show_bug.cgi?id=215575) which is definitely bug.
Comment 1 Milos Kleint 2012-07-16 16:23:48 UTC
with Compile on Save enabled, the subsequent executions will be performed by the IDE. That's unfortunately done through Ant further increasing confusion.

if Compile on Save doesn't work for you, just disable it. It's only working for the simple cases, please be aware however that the Ant execution is only part of the Compile on Save functionality, specifically tailored for jar based projects with a main method. For war projects we (re)deploy the apps for example. And CoS can also be used together with jrebel or javeleon for live class reloading.
Comment 2 evillive 2012-07-17 10:35:45 UTC
Milos,
Thanks! Disabling Compile on Save works for me. Now I see that was designed behavior. Should I change status to RESOLVED (I cannot see INVALID option)?
Could you please look at http://netbeans.org/bugzilla/show_bug.cgi?id=215575 ?
That is the only thing, that blocks me from using 'Compile on Save' feature.
Comment 3 Milos Kleint 2012-10-31 08:39:24 UTC
-> P1, TASK. not to be immediately fixed, but in the long term we should keep using maven even for quick executions without compilation
Comment 4 Milos Kleint 2013-02-21 12:34:00 UTC
https://hg.netbeans.org/core-main/rev/2a24101df218


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo