Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 215454 - Browser opened at wrong address for Maven EAR application
Browser opened at wrong address for Maven EAR application
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Maven
7.2
PC Windows 7
: P3 (vote)
: 7.2.1
Assigned To: Martin Janicek
issues@javaee
72patch1-verified
:
: 216218 218420 222756 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 12:00 UTC by Jiri Skrivanek
Modified: 2015-08-12 08:34 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2012-07-12 12:00:23 UTC
Browser is opened at http://localhost:8080/mavenproject14-web-1.0-SNAPSHOT instead of http://localhost:8080/mavenproject14-web/ for Maven EAR application. To reproduce:

- open new project wizard
- choose "Maven|Enterprise Application" and finish the wizard
- add session bean with business method to -ejb sub project
- build main project
- run -ear project. It opens browser at address http://localhost:8080/mavenproject14-web-1.0-SNAPSHOT which is invalid

Product Version: NetBeans IDE 7.2 (Build 201207101812)
Java: 1.7.0_06-ea; Java HotSpot(TM) 64-Bit Server VM 23.2-b08
System: Windows 7 version 6.1 running on amd64; Cp1250; en_US (nb)
Comment 1 Martin Janicek 2012-07-30 08:07:50 UTC
Fixed together with issue 215976 in: web-main #752b7ed13c51
Comment 2 Quality Engineering 2012-07-31 02:34:11 UTC
Integrated into 'main-golden', will be available in build *201207310001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/752b7ed13c51
User: Martin Janicek <mjanicek@netbeans.org>
Log: #215454 + #215976 - Redeployment doesnt works for maven EAR project.
Comment 3 Jiri Skrivanek 2012-08-01 07:35:22 UTC
*** Bug 216218 has been marked as a duplicate of this bug. ***
Comment 4 Vladimir Riha 2012-08-29 11:24:40 UTC
verified

Product Version: NetBeans IDE Dev (Build 201208290001)
Java: 1.7.0_06; Java HotSpot(TM) Client VM 23.2-b09
System: Linux version 3.2.0-29-generic-pae running on i386; UTF-8; en_US (nb)
Comment 5 Martin Janicek 2012-08-31 08:24:15 UTC
I'm changing the whiteboard to 72patch1-fixed as the fix was already transplanted into the release branch withtin the issue 215976:

- http://hg.netbeans.org/releases/rev/e422546e8548
- http://hg.netbeans.org/releases/rev/f3fc5886aa5a

..see issue 215976, comment 20 for more details
Comment 6 Quality Engineering 2012-09-01 11:08:35 UTC
Integrated into 'releases', will be available in build *201209010822* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/e422546e8548
User: Martin Janicek <mjanicek@netbeans.org>
Log: #215454 + #215976 - Redeployment doesnt works for maven EAR project.
(transplanted from 752b7ed13c511ee8162c89e84718de2b0931dc1f)
Comment 7 Martin Janicek 2012-09-20 06:32:21 UTC
*** Bug 218420 has been marked as a duplicate of this bug. ***
Comment 8 Tomas Danek 2012-11-27 11:45:38 UTC
*** Bug 222756 has been marked as a duplicate of this bug. ***
Comment 9 athompson 2013-04-30 00:44:30 UTC
Not working again in 7.4 daily. Netbeans actually opens a different invalid address than before (http://localhost:8080/mavenproject14-ear instead of http://localhost:8080/mavenproject14-web), but I reopened this bug because reproduction is the same, it's related to issue #215976 which also needs to be reopened, and I flipped a coin. Let me know if I should create a new issue instead.
Comment 10 athompson 2013-04-30 00:45:08 UTC
Product Version: NetBeans IDE Dev (Build 201304252301)
Updates: Updates available
Java: 1.7.0_21; Java HotSpot(TM) 64-Bit Server VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b12
System: Mac OS X version 10.8.4 running on x86_64; US-ASCII; en_US (nb)
User directory: /Users/alvin/Library/Application Support/NetBeans/dev
Cache directory: /Users/alvin/Library/Caches/NetBeans/dev
Comment 11 Petr Jiricka 2013-04-30 05:54:06 UTC
Is this in 7.4 only, or also in 7.3.1?
Comment 12 Martin Janicek 2013-06-11 13:50:35 UTC
Closing back to FIXED. The problem still exists, but it's a duplicate of the issue 229328 (the fix will be almost certainly the same for both problems). Please follow the issue 229328 instead of this one.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo