Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 215116 - Slow down after a few hours of use
Slow down after a few hours of use
Status: RESOLVED DUPLICATE of bug 215159
Product: projects
Classification: Unclassified
Component: Maven
7.2
PC Windows 7
: P3 (vote)
: 7.3
Assigned To: Milos Kleint
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 10:03 UTC by mienamoo
Modified: 2012-11-05 14:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (421.83 KB, application/octet-stream)
2012-07-03 10:03 UTC, mienamoo
Details
Snapshot (19.74 KB, application/octet-stream)
2012-07-03 10:04 UTC, mienamoo
Details
Snapshot (163.20 KB, application/octet-stream)
2012-07-03 10:05 UTC, mienamoo
Details
Snapshot (33.02 KB, application/octet-stream)
2012-07-03 10:05 UTC, mienamoo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mienamoo 2012-07-03 10:03:41 UTC
Created attachment 121688 [details]
IDE log

NetBeans build 201206291011
JDK 7u5 32-bit

I am working on a Maven-based NetBeans platform application, with a JavaEE backend. So I have been running GlassFish from the IDE for the past about 4 hours (with a fair amount of logging going to the output window), and starting and stopping and debugging the front end app.

The IDE was using more and more memory, until it now finally is becoming unresponsive. Not completely unresponsive yet, just sluggish.

Please see attached the messages.log file and snapshots.

I have noticed that this is specific to the 32-bit JDK.
Comment 1 mienamoo 2012-07-03 10:04:35 UTC
Created attachment 121689 [details]
Snapshot
Comment 2 mienamoo 2012-07-03 10:05:04 UTC
Created attachment 121690 [details]
Snapshot
Comment 3 mienamoo 2012-07-03 10:05:26 UTC
Created attachment 121691 [details]
Snapshot
Comment 4 mienamoo 2012-07-03 10:13:49 UTC
I will provide the link to the heap dump as soon as the upload completes. :)
Comment 5 aquaglia 2012-07-03 10:36:43 UTC
I opened bug 212479 some time ago.
Seems a similar issue.
Comment 6 mienamoo 2012-07-03 10:57:44 UTC
And finally the heap dump upload is complete. :)

https://www.dropbox.com/s/qu7a6bbseue78um/nb72-heapdump-1341308747690.zip
Comment 7 Petr Cyhelsky 2012-10-31 16:09:40 UTC
the memory consumption doesn't seem to be very high considering the 61 open maven projects most of which takes up 2-3 MB, but reassigning to maven for evaluation anyway. Milos, can you please look at the heap dump for oddities - like 76 instances of org.netbeans.modules.maven.execute.AbstractMavenExecutor$ReRunAction is it normal?
Comment 8 Milos Kleint 2012-11-05 14:17:20 UTC
There is a significantly high number of o.apache.maven.model.Model instances (2700+) compared to the number of o.a.maven.project.MavenProject instances (67)

for 7.3 I've reduced the number of Model instances to something like 2x MavenProject as a long term trend, can spike a bit here and there.

the sluggish-ness can be explained by you reaching a limit where SoftReferences got released. MavenProject is held by a SoftReference as well, it's generally used though for open (and sometimes not open) proiects, and you ended up in a vicious cycle of loading MavenProject instances and immediately releasing the again.
Comment 9 Milos Kleint 2012-11-05 14:31:01 UTC
I'm going to mark it as duplicate of issue 215159, please reopen if he problem persists in 7.3 beta/beta2.

Thank you.

*** This bug has been marked as a duplicate of bug 215159 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo