Bug 214836 - NullPointerException at com.sun.tools.javac.comp.Lower.visitNewClass
NullPointerException at com.sun.tools.javac.comp.Lower.visitNewClass
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.1
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 04:44 UTC by Exceptions Reporter
Modified: 2015-09-17 11:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (6.00 KB, text/plain)
2012-06-27 04:44 UTC, Exceptions Reporter
Details
stacktrace (6.28 KB, text/plain)
2013-02-14 11:40 UTC, Jaroslav Tulach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-06-27 04:44:36 UTC
This bug was originally marked as duplicate of bug 165317, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.1.2 (Build 201204101705)
VM: Java HotSpot(TM) Client VM, 14.3-b01, Java(TM) SE Runtime Environment, 1.6.0_17-b04
OS: Windows 7

Stacktrace: 
java.lang.NullPointerException
   at com.sun.tools.javac.comp.Lower.visitNewClass(Lower.java:2652)
   at com.sun.tools.javac.tree.JCTree$JCNewClass.accept(JCTree.java:1377)
   at com.sun.tools.javac.tree.TreeTranslator.translate(TreeTranslator.java:58)
   at com.sun.tools.javac.comp.Lower.translate(Lower.java:2172)
   at com.sun.tools.javac.tree.TreeTranslator.visitThrow(TreeTranslator.java:261)
   at com.sun.tools.javac.tree.JCTree$JCThrow.accept(JCTree.java:1268)
Comment 1 Exceptions Reporter 2012-06-27 04:44:40 UTC
Created attachment 121420 [details]
stacktrace
Comment 2 Jaroslav Tulach 2013-02-14 11:40:48 UTC
Created attachment 131381 [details]
stacktrace
Comment 3 Martin Balin 2015-09-17 11:20:49 UTC
Report from old NetBeans version. Due to code changes since it was reported likely not reproducible now. Feel free to reopen if happens in 8.0.2 or 8.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo