Bug 214649 - NullPointerException at com.sun.tools.javac.comp.Attr.visitNewClass
NullPointerException at com.sun.tools.javac.comp.Attr.visitNewClass
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.2
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 21:38 UTC by davideconsonni
Modified: 2015-09-17 11:18 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.42 KB, text/plain)
2012-06-22 21:38 UTC, davideconsonni
Details

Note You need to log in before you can comment on or make changes to this bug.
Description davideconsonni 2012-06-22 21:38:37 UTC
Build: NetBeans IDE 7.2 Beta (Build 201205031832)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b22
OS: Windows 7

Stacktrace: 
java.lang.NullPointerException
   at com.sun.tools.javac.comp.Attr.visitNewClass(Attr.java:1867)
   at com.sun.tools.javac.tree.JCTree$JCNewClass.accept(JCTree.java:1377)
   at com.sun.tools.javac.comp.Attr.attribTree(Attr.java:451)
   at com.sun.tools.javac.comp.Attr.attribTree(Attr.java:424)
   at com.sun.tools.javac.comp.Attr.attribExpr(Attr.java:470)
   at com.sun.tools.javac.comp.Annotate.enterAttributeValue(Annotate.java:229)
Comment 1 davideconsonni 2012-06-22 21:38:42 UTC
Created attachment 121241 [details]
stacktrace
Comment 2 Martin Balin 2015-09-17 11:18:17 UTC
Report from old NetBeans version. Due to code changes since it was reported likely not reproducible now. Feel free to reopen if happens in 8.0.2 or 8.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo