Bug 214546 - White text on white background
White text on white background
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Output Window
7.2
All All
: P3 (vote)
: 7.3
Assigned To: Jaroslav Havlin
issues@platform
:
: 213883 (view as bug list)
Depends on:
Blocks: 214494
  Show dependency treegraph
 
Reported: 2012-06-21 04:14 UTC by Tomas Mysik
Modified: 2012-09-24 07:24 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2012-06-21 04:14:06 UTC
For motivation for this report, please, read issue #214494.

The problem is that in PHP, we run an external task which supports colored output. But this task is ready for "black" terminal only so it uses white color for some of its output (and we cannot change or configure it since there is no such possibility). Of course, white text is not visible on white background...

Would it make sense to change color of text to black if the color is white? Or, more generally, to revert text color if it is the same as the color of a background?

Thanks.
Comment 1 Jaroslav Havlin 2012-07-27 09:31:08 UTC
http://hg.netbeans.org/core-main/rev/b777008eeb76
Added support for ANSI background colors.

Please consider this support experimental. If some serious problems appear, it might be reverted.

> Would it make sense to change color of text to black if the color is white? Or,
> more generally, to revert text color if it is the same as the color of a
> background?
This make sense. The foreground color is changed if it is very similar to the background color.

Please check whether the output is correctly colored now (issue #214494).
Thank you.
Comment 2 Quality Engineering 2012-07-28 02:23:19 UTC
Integrated into 'main-golden', will be available in build *201207280002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/b777008eeb76
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #214546: Support for ANSI background colors
Comment 3 Vladimir Riha 2012-07-30 06:47:38 UTC
Thanks, it is. Now the error msg has red background color (exactly like in system terminal) with white font


Product Version: NetBeans IDE Dev (Build 201207300002)
Java: 1.7.0_06-ea; Java HotSpot(TM) Client VM 23.2-b09
System: Linux version 3.0.0-21-generic-pae running on i386; UTF-8; en_US (nb)
Comment 4 Jaroslav Havlin 2012-09-24 07:24:57 UTC
*** Bug 213883 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo