Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 214515 - REQ: Copy filename from tab
REQ: Copy filename from tab
Status: RESOLVED DUPLICATE of bug 153728
Product: editor
Classification: Unclassified
Component: Navigation
7.2
Macintosh (x86) Mac OS X
: P3 (vote)
: 7.4
Assigned To: Milutin Kristofic
issues@editor
issue_reviewed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 13:53 UTC by markuszeller
Modified: 2013-10-03 11:57 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description markuszeller 2012-06-20 13:53:07 UTC
When using complex projects it would be helpful, if the filename of the current open tab could be copied into the clipboard.

Example:
Working on "template.html" and want to find all files including "template.html".
Comment 1 Petr Somol 2012-06-21 08:25:56 UTC
might there also be a use case for copying full-path name instead of just the simple name ? It seems so to me..
Comment 2 markuszeller 2012-06-21 08:42:10 UTC
That could also be useful :D

So maybe the developers could integrate "filename", "full path", "full path + filename" as context menu?
Comment 3 Petr Somol 2012-06-21 08:49:33 UTC
Well, we face the concern of pop-up menu length which is also quite important, but one item could perhaps make it (possibly leading to sub-menu). Can't promise though, it will depend on overall evaluation of menu contents..
Comment 4 markiewb 2012-09-25 18:17:59 UTC
Duplicate of http://netbeans.org/bugzilla/show_bug.cgi?id=153728 ?

Full path can be copied already.
Comment 5 Milutin Kristofic 2013-10-03 11:57:07 UTC
I would say it is duplicate of #153728. Markus if you think this is different requirement, please reopen and describe difference. Thank you

*** This bug has been marked as a duplicate of bug 153728 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo