Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 214501 - mi_cmd_var_update:USAGE:NAME.
mi_cmd_var_update:USAGE:NAME.
Status: RESOLVED INCOMPLETE
Product: cnd
Classification: Unclassified
Component: Debugger
7.2
PC Linux
: P1 (vote)
: TBD
Assigned To: Egor Ushakov
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 11:00 UTC by _ pandajava
Modified: 2012-06-21 14:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Debugger Error for Attaching Remote process to debugger (157.44 KB, image/jpeg)
2012-06-20 11:00 UTC, _ pandajava
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ pandajava 2012-06-20 11:00:11 UTC
Created attachment 121093 [details]
Debugger Error for  Attaching Remote process to debugger

Debugger error during attaching remote process to debugger.
Here the message : mi_cmd_var_update:USAGE:NAME.

And the picture is attached.
Comment 1 henk89 2012-06-20 13:19:04 UTC
Could you attach gdblog, please?
http://wiki.netbeans.org/GdbLog
Comment 2 Alexander Pepin 2012-06-20 14:28:01 UTC
To pandajava: As I can see you tried to attach to makefile based Quote project. Could you please provide more details about your systems (local and remote) and type of synchronization (File Sharing or Automatic copying) and exact performed steps as I can not reproduce the problem.
Comment 3 Egor Ushakov 2012-06-20 14:50:14 UTC
from the screenshot it looks like remote, what platform was that?
Comment 4 _ pandajava 2012-06-20 14:55:22 UTC
(In reply to comment #2)
> To pandajava: As I can see you tried to attach to makefile based Quote project.
> Could you please provide more details about your systems (local and remote) and
> type of synchronization (File Sharing or Automatic copying) and exact performed
> steps as I can not reproduce the problem.

I use Fedora 16 as local system and Unbreakable Linux as remote server. The synchronization is Automatic copying. 

Steps : 
I unzip  the sample (http://wiki.netbeans.org/wiki/images/3/36/Quote_mkfb.tar) of project on remote.
I create a remote project with existing sources.
I run the project and launch "Attach Debugger" from menu item. Search the process and attach the process to debugger. 

(In reply to comment #2)
> To pandajava: As I can see you tried to attach to makefile based Quote project.
> Could you please provide more details about your systems (local and remote) and
> type of synchronization (File Sharing or Automatic copying) and exact performed
> steps as I can not reproduce the problem.

I use Fedora 16 as local system and Unbreakable Linux as remote server. The synchronization is Automatic copying. 

Steps : 
I unzip  the sample (http://wiki.netbeans.org/wiki/images/3/36/Quote_mkfb.tar) of project on remote.
I create a remote project with existing sources.
I run the project and launch "Attach Debugger" from menu item. Search the process and attach the process to debugger.
Comment 5 _ pandajava 2012-06-20 15:47:01 UTC
(In reply to comment #3)
> from the screenshot it looks like remote, what platform was that?

The remote system is Unbreakable Linux (Compatible Red Hat) and the local host is Fedora 16
Comment 6 Alexander Pepin 2012-06-20 16:52:56 UTC
Could you please attach gdb log (http://wiki.netbeans.org/GdbLog)

I still can not reproduce the bug.
In your steps the first step looks suspicious (I unzip  the sample (http://wiki.netbeans.org/wiki/images/3/36/Quote_mkfb.tar)
of project on remote.)
You should unzip the sample on the local host! Then add and choose a remote build host. 
There is one tricky step where you should set the path to the executable on remote host in the ProjectProperties->Build->Make->BuildResult field. It should be a local path on the remote host.
Comment 7 _ pandajava 2012-06-20 17:08:29 UTC
(In reply to comment #6)
> Could you please attach gdb log (http://wiki.netbeans.org/GdbLog)
> 
> I still can not reproduce the bug.
> In your steps the first step looks suspicious (I unzip  the sample
> (http://wiki.netbeans.org/wiki/images/3/36/Quote_mkfb.tar)
> of project on remote.)
> You should unzip the sample on the local host! Then add and choose a remote
> build host. 
> There is one tricky step where you should set the path to the executable on
> remote host in the ProjectProperties->Build->Make->BuildResult field. It should
> be a local path on the remote host.

Oki dok, 
I try and back to you soon !
Comment 8 Egor Ushakov 2012-06-21 14:58:26 UTC
please reopen with more data (gdblog), incomplete until then


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo