Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 214497 - Remote synchronization for folders
Remote synchronization for folders
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: FTP Support
7.2
All All
: P2 with 2 votes (vote)
: 8.0
Assigned To: Tomas Mysik
issues@php
:
: 228512 235943 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 10:30 UTC by markuszeller
Modified: 2013-09-26 04:56 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Your requested messages.log (37.58 KB, application/octet-stream)
2012-06-25 07:25 UTC, markuszeller
Details
Your requested thread dump (30.54 KB, application/octet-stream)
2012-06-25 07:26 UTC, markuszeller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description markuszeller 2012-06-20 10:30:57 UTC
The FTP Sync is magnificent! Thanks for your great work.

Please enable that sync feature by right clicking on any folder. Also please enable right click ignore instead of opening the project settings.
Comment 1 Tomas Mysik 2012-06-21 03:58:45 UTC
(In reply to comment #0)
> The FTP Sync is magnificent! Thanks for your great work.

Thanks for your positive feedback.

> Please enable that sync feature by right clicking on any folder.

Unfortunately not as easy as it seems.

> Also please
> enable right click ignore instead of opening the project settings.

What do you mean by that? Can you provide steps to reproduce? IS it related to the "sync feature by right clicking on any folder"? If not, please, do NOT solve it in this issue. Simply create a new bug/enhancement.

Thanks.
Comment 2 markuszeller 2012-06-21 08:40:18 UTC
Sometimes, there are folders I do not need to sync at all, like tmp, cache, downloads, uploads, etc. So I go to the project settings and put those on to the exclude list.

Then they are ignored by the FTP syncing as expected.
It would be nice, to right click on those folders and put them directly to the ignore list. (as like you can do with a git project folder).

So this is no bug, but an enhancement request.
Comment 3 Tomas Mysik 2012-06-21 08:44:16 UTC
(In reply to comment #2)
> Sometimes, there are folders I do not need to sync at all, like tmp, cache,
> downloads, uploads, etc. So I go to the project settings and put those on to
> the exclude list.
> 
> Then they are ignored by the FTP syncing as expected.
> It would be nice, to right click on those folders and put them directly to the
> ignore list. (as like you can do with a git project folder).
> 
> So this is no bug, but an enhancement request.

Not related to this report; reported as issue #214557.

Thanks.
Comment 4 markuszeller 2012-06-25 07:25:50 UTC
Created attachment 121273 [details]
Your requested messages.log
Comment 5 markuszeller 2012-06-25 07:26:21 UTC
Created attachment 121274 [details]
Your requested thread dump
Comment 6 Tomas Mysik 2012-06-25 08:10:16 UTC
Sorry, I did not ask for messages.log or thread dump. Or am I missing something?

Thanks.
Comment 7 markuszeller 2012-06-25 08:20:31 UTC
Oh, I'm sorry. It was intended for Bug #214500
Comment 8 Tomas Mysik 2013-04-12 12:23:08 UTC
*** Bug 228512 has been marked as a duplicate of this bug. ***
Comment 9 xmak 2013-06-30 10:55:34 UTC
+1 from me

Both Aptana and PHP Storm have such a feature to sync only specific folders, so if they can do it...

I have been using Aptana for some time now, and currently I'm thinking of migrating to netbeans and the only thing that stops me from that is the lack of this folder sync feature.
Comment 10 Tomas Mysik 2013-09-19 09:29:32 UTC
*** Bug 235943 has been marked as a duplicate of this bug. ***
Comment 11 Tomas Mysik 2013-09-24 06:24:09 UTC
Should be done now - feel free to test it and let us know so we can fix/improve it.

@mmolda, @vriha: Guys, if you could test it (sync one or more files, one or more directories and whole project), it would be great.

Thanks.

http://hg.netbeans.org/web-main/rev/ef495b3d497e
Comment 12 Tomas Mysik 2013-09-24 06:46:36 UTC
One more changeset.

http://hg.netbeans.org/web-main/rev/e7518e050997
Comment 13 Quality Engineering 2013-09-25 02:06:24 UTC
Integrated into 'main-silver', will be available in build *201309250002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/ef495b3d497e
User: Tomas Mysik <tmysik@netbeans.org>
Log: #214497 - Remote synchronization for folders
Comment 14 mmolda 2013-09-25 09:29:29 UTC
Tomasi,
I have just tested it and I found no problem :)
I tested right click sync on one file, more files, one directory, more directories, directory with subdirectories, more files and directories, whole project. Everything works good!

Product Version: NetBeans IDE Dev (Build 201309250002)
Java: 1.7.0_40; Java HotSpot(TM) 64-Bit Server VM 24.0-b56
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b43
System: Windows 7 version 6.1 running on amd64; Cp1250; en_US (nb)
Comment 15 Tomas Mysik 2013-09-25 10:20:00 UTC
Thanks for the verification, Milane!
Comment 16 wizhippo 2013-09-25 16:25:45 UTC
File stamps on the local/remote are not changed/synced(Is this as expected?).  If I select a file to sync, upload it then sync again the same file shows it needs to be synced again.

All else works as expected.
Comment 17 Tomas Mysik 2013-09-26 04:56:03 UTC
Please, do not change status of this issue; feel free to create a new one. Thanks.

(In reply to wizhippo from comment #16)
> File stamps on the local/remote are not changed/synced(Is this as
> expected?).

Yes.

> If I select a file to sync, upload it then sync again the same
> file shows it needs to be synced again.

Please, report it as a new issue with exact steps to reproduce. Please note that NetBeans remembers synchronization timestamps only for folders, not for files.

Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo