Bug 214161 - ArrayIndexOutOfBoundsException: -1
ArrayIndexOutOfBoundsException: -1
Status: VERIFIED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
7.2
All All
: P1 (vote)
: 7.2
Assigned To: Tomas Stupka
issues@connecteddeveloper
EXCEPTIONS_REPORT
: 72_HR_FIX
: 214889 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 22:20 UTC by jgish
Modified: 2012-06-28 16:51 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.48 KB, text/plain)
2012-06-13 22:20 UTC, jgish
Details
stacktrace (1.48 KB, text/plain)
2012-06-27 13:50 UTC, javydreamercsw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jgish 2012-06-13 22:20:22 UTC
Build: NetBeans IDE Dev (Build jdk8lambda-1529-on-20120612)
VM: OpenJDK Client VM, 22.0-b10, OpenJDK Runtime Environment, 1.7.0_03-b147
OS: Linux

User Comments:
GUEST: Using JIRA plugin:

Always receive an error when changing from and normal tab (i.e. .java code) to find Issues tab.

The find issues tab currently shows a query containing all my open tasks. It does not matter by which column the results table is sorted. An error always  occurs.

GUEST: Using JIRA plugin:

Always receive an error when changing from and normal tab (i.e. .java code) to find Issues tab.

The find issues tab currently shows a query containing all my open tasks. It does not matter by which column the results table is sorted. An error always  occurs.

jgish: Refreshing a JIRA query

GUEST: Using JIRA plugin:

Always receive an error when changing from and normal tab (i.e. .java code) to find Issues tab.

The find issues tab currently shows a query containing all my open tasks. It does not matter by which column the results table is sorted. An error always  occurs.

GUEST: Open Jira plugin

GUEST: Using JIRA plugin:

Always receive an error when changing from and normal tab (i.e. .java code) to find Issues tab.

The find issues tab currently shows a query containing all my open tasks. It does not matter by which column the results table is sorted. An error always  occurs.




Stacktrace: 
java.lang.ArrayIndexOutOfBoundsException: -1
   at java.util.Vector.elementData(Vector.java:730)
   at java.util.Vector.elementAt(Vector.java:473)
   at javax.swing.table.DefaultTableColumnModel.getColumn(DefaultTableColumnModel.java:294)
   at org.netbeans.modules.bugtracking.issuetable.IssueTable$5.setColumnWidth(IssueTable.java:581)
   at org.netbeans.modules.bugtracking.issuetable.IssueTable$5.run(IssueTable.java:569)
   at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
Comment 1 jgish 2012-06-13 22:20:29 UTC
Created attachment 120803 [details]
stacktrace
Comment 2 Tomas Stupka 2012-06-15 14:13:12 UTC
could reproduce:  
- invoke find issue on a jira repository 
- setup the query and save  
- switch to some another tab, switch back to the query -> the exception is raised  

happens for every newly created jira query. After nb restart the problem is gone.  highly visible -> P1
Comment 3 Tomas Stupka 2012-06-15 14:28:29 UTC
fixed in core-main #826fbac2ecc3
Comment 4 Quality Engineering 2012-06-16 06:05:58 UTC
Integrated into 'main-golden', will be available in build *201206160001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/826fbac2ecc3
User: Tomas Stupka <tstupka@netbeans.org>
Log: Issue #214161 - ArrayIndexOutOfBoundsException: -1
Comment 5 Stepan Zebra 2012-06-25 06:59:53 UTC
verified in 1.12.0
Comment 6 Marian Mirilovic 2012-06-25 07:39:16 UTC
Ok, proceed with integration into release72 ... pending verification in NB 7.2
Comment 7 Tomas Stupka 2012-06-26 15:47:25 UTC
integrated into 7.2
releases #fbdc333bf0c1
Comment 8 Quality Engineering 2012-06-27 03:06:38 UTC
Integrated into 'releases', will be available in build *201206262201* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/fbdc333bf0c1
User: Tomas Stupka <tstupka@netbeans.org>
Log: issue #214161 - ArrayIndexOutOfBoundsException: -1
Comment 9 javydreamercsw 2012-06-27 13:50:05 UTC
Created attachment 121449 [details]
stacktrace

Selected Mark All Issues as seen from the issue search result
Comment 10 Tomas Stupka 2012-06-28 08:07:21 UTC
*** Bug 214889 has been marked as a duplicate of this bug. ***
Comment 11 Stepan Zebra 2012-06-28 13:24:49 UTC
verified in 7.2 RC
Comment 12 javydreamercsw 2012-06-28 16:11:11 UTC
Do you mean 7.2 RC1 or 2? My report came from 7.2 RC1
Comment 13 Tomas Stupka 2012-06-28 16:51:09 UTC
(In reply to comment #12)
> Do you mean 7.2 RC1 or 2? My report came from 7.2 RC1
the fixed module was populated on the UC today, after you have reported


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo