Bug 214012 - PathRegistry.createResources AssertionError: file://server/share/path/to/project/src/
PathRegistry.createResources AssertionError: file://server/share/path/to/proj...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Jesse Glick
issues@editor
EXCEPTIONS_REPORT
:
: 214393 214394 214396 214398 214399 214400 (view as bug list)
Depends on:
Blocks: 213562
  Show dependency treegraph
 
Reported: 2012-06-11 21:01 UTC by Jesse Glick
Modified: 2012-06-18 18:08 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (8.88 KB, text/plain)
2012-06-11 21:01 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-06-11 21:01:09 UTC
This bug was originally marked as duplicate of bug 206467, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 20120611-5951a50a6f9a)
VM: Java HotSpot(TM) Client VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b22
OS: Windows XP

Stacktrace: 
java.lang.AssertionError: file://vboxsvr/space/src/nb/main/projectapi/src/
   at org.netbeans.modules.parsing.impl.indexing.PathRegistry.createResources(PathRegistry.java:621)
   at org.netbeans.modules.parsing.impl.indexing.PathRegistry.getPathIdToRoots(PathRegistry.java:575)
   at org.netbeans.modules.parsing.impl.indexing.PathRegistry.getRootsMarkedAs(PathRegistry.java:444)
   at org.netbeans.modules.parsing.spi.indexing.support.QuerySupport.getClasspathRoots(QuerySupport.java:427)
   at org.netbeans.modules.parsing.spi.indexing.support.QuerySupport.collectClasspathRoots(QuerySupport.java:386)
   at org.netbeans.modules.parsing.spi.indexing.support.QuerySupport.findRoots(QuerySupport.java:195)
Comment 1 Jesse Glick 2012-06-11 21:01:15 UTC
Created attachment 120702 [details]
stacktrace
Comment 2 Jesse Glick 2012-06-11 22:04:36 UTC
core-main #dd7fd93bd1eb
Comment 3 Quality Engineering 2012-06-14 06:10:18 UTC
Integrated into 'main-golden', will be available in build *201206140001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/dd7fd93bd1eb
User: Jesse Glick <jglick@netbeans.org>
Log: #214012: a couple of Parsing-related UNC fixes.
Comment 4 Tomas Zezula 2012-06-18 17:54:29 UTC
*** Bug 214393 has been marked as a duplicate of this bug. ***
Comment 5 Tomas Zezula 2012-06-18 17:55:37 UTC
*** Bug 214394 has been marked as a duplicate of this bug. ***
Comment 6 Tomas Zezula 2012-06-18 17:55:41 UTC
*** Bug 214396 has been marked as a duplicate of this bug. ***
Comment 7 Tomas Zezula 2012-06-18 17:57:43 UTC
*** Bug 214398 has been marked as a duplicate of this bug. ***
Comment 8 Tomas Zezula 2012-06-18 18:01:38 UTC
*** Bug 214399 has been marked as a duplicate of this bug. ***
Comment 9 Tomas Zezula 2012-06-18 18:08:33 UTC
*** Bug 214400 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo