Bug 214011 - java.nio.file.InvalidPathException: Illegal char <:> at index 0: ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
java.nio.file.InvalidPathException: Illegal char <:> at index 0: ::{20D04FE0-...
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Jesse Glick
issues@projects
EXCEPTIONS_REPORT
:
: 214038 (view as bug list)
Depends on:
Blocks: 213562
  Show dependency treegraph
 
Reported: 2012-06-11 20:55 UTC by Jesse Glick
Modified: 2012-06-18 05:49 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.36 KB, text/plain)
2012-06-11 20:55 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-06-11 20:55:05 UTC
Build: NetBeans IDE Dev (Build 20120611-5951a50a6f9a)
VM: Java HotSpot(TM) Client VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b22
OS: Windows XP

User Comments:
jglick: Directory chooser.




Stacktrace: 
java.nio.file.InvalidPathException: Illegal char <:> at index 0: ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
   at sun.nio.fs.WindowsPathParser.normalize(WindowsPathParser.java:176)
   at sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:147)
   at sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:77)
   at sun.nio.fs.WindowsPath.parse(WindowsPath.java:94)
   at sun.nio.fs.WindowsFileSystem.getPath(WindowsFileSystem.java:255)
   at java.io.File.toPath(File.java:2069)
Comment 1 Jesse Glick 2012-06-11 20:55:11 UTC
Created attachment 120697 [details]
stacktrace
Comment 2 Jesse Glick 2012-06-11 21:29:43 UTC
core-main #452608a6a731
Comment 3 Jesse Glick 2012-06-12 18:40:33 UTC
*** Bug 214038 has been marked as a duplicate of this bug. ***
Comment 4 Quality Engineering 2012-06-14 06:10:06 UTC
Integrated into 'main-golden', will be available in build *201206140001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/452608a6a731
User: Jesse Glick <jglick@netbeans.org>
Log: #214011: exceptions when trying to deal with special shell files like "My Computer".
Comment 5 kolen 2012-06-18 05:49:01 UTC
Not occurs anymore in 201206170001 (successfully starts with java 1.7.0 1.7.0_05-b05 client vm 23.1-b03).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo