Bug 213956 - NoClassDefFoundError: org/openide/util/actions/CallableSystemAction$1
NoClassDefFoundError: org/openide/util/actions/CallableSystemAction$1
Status: RESOLVED DUPLICATE of bug 211962
Product: platform
Classification: Unclassified
Component: Module System
7.0
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 10:55 UTC by Exceptions Reporter
Modified: 2012-06-11 14:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.96 KB, text/plain)
2012-06-11 10:55 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-06-11 10:55:09 UTC
This issue was reported manually by mmirilovic.
It already has 20 duplicates 


Build: NetBeans IDE 7.0.1 (Build 201107282000)
VM: Java HotSpot(TM) Client VM, 20.5-b03, Java(TM) SE Runtime Environment, 1.6.0_30-b12
OS: Windows 7

User Comments:
GUEST: quiting from ide

GUEST: Trying to exit using File / Exit

GUEST: Trying to drag-and-drop one webservice reference from the left Project browser to the right Editor Pane.

GUEST: File | Exit

GUEST: Tried to use File->Exit menu selection.

GUEST: Could not start GlassFish 3.1.2 severla times; decided to EXIT NB, and restart my VISTA machine. When this exception occured.

GUEST: Trying to close IDE via "exit".
I'm getting such ClassNotFoundException on various system actions for Nodes: "Delete" ,...
That's completely block my work.
Only IDE restart helps. But exception can appear at any time with other action.

GUEST: I recieved this error in 2 places
- right click on Web Service Refrence in the Projects Window
- File - Exit

As a work arouond I close the window with the X, then kill all java processes, then restart Netbeans
The Right Click and File Exit will work until I rebuild the project.
The project does have errors

GUEST: I get this error every time I click the File / Exit menu.

GUEST: ending netbeans




Stacktrace: 
java.lang.NoClassDefFoundError: org/openide/util/actions/CallableSystemAction$1
   at org.openide.util.actions.CallableSystemAction.actionPerformed(CallableSystemAction.java:126)
   at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
   at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
   at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
   at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
   at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
Comment 1 Exceptions Reporter 2012-06-11 10:55:16 UTC
Created attachment 120655 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-06-11 14:32:47 UTC

*** This bug has been marked as a duplicate of bug 211962 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo