Bug 213950 - [HeapWalker] ClassesListControllerUI is held in memory via JProgressBar
[HeapWalker] ClassesListControllerUI is held in memory via JProgressBar
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
7.2
PC Mac OS X
: P3 (vote)
: 7.2
Assigned To: Tomas Hurka
issues@profiler
: VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 09:29 UTC by Tomas Hurka
Modified: 2012-09-27 15:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Hurka 2012-06-11 09:29:09 UTC
ClassesListControllerUI is held in memory via JProgressBar. This looks like Mac OS X problem.
Comment 1 Tomas Hurka 2012-06-11 09:39:55 UTC
Fixed in profiler-main. 

changeset:   224112:296d67646fb9
user:        Tomas Hurka <thurka@netbeans.org>
date:        Mon Jun 11 11:37:02 2012 +0200
summary:     bugfix #213950, the problem is caused by p.setIndeterminate(true), which attach JProgress to a timer
Comment 2 Quality Engineering 2012-06-13 06:09:17 UTC
Integrated into 'main-golden', will be available in build *201206130001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/296d67646fb9
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #213950, the problem is caused by p.setIndeterminate(true), which attach JProgress to a timer


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo