Bug 213855 - git pull --rebase
git pull --rebase
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Git
7.1.2
PC All
: P3 with 1 vote (vote)
: 7.4
Assigned To: Ondrej Vrabec
issues@versioncontrol
: PLAN
Depends on: 226545
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 19:31 UTC by sparkee
Modified: 2013-08-01 15:19 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sparkee 2012-06-08 19:31:37 UTC
Git pull with rebase would be a really handy thing to have.  When working on a large project with multiple developers, it is very useful for helping everybody ensure they are working against the master branch.

See also similar bug reports 188685 and 206418 for Mercurial.
Comment 1 ymajoros 2013-01-14 12:20:32 UTC
I volunteer for this as well. Could we just start from merge? I guess we then will  some simple actions for handling rebase conflicts: continue/abort/skip rebase...
Comment 2 ymajoros 2013-01-14 12:53:55 UTC
(In reply to comment #1)
> I volunteer for this as well. Could we just start from merge? I guess we then
> will  some simple actions for handling rebase conflicts: continue/abort/skip
> rebase...

Sorry, forget about this comment, one, it was intended for #221661
Comment 3 creechy 2013-02-13 16:54:44 UTC
+1 to this. Would drastically improve the usefulness of NetBeans with Git.
Comment 4 Ondrej Vrabec 2013-03-19 09:09:40 UTC
fix: http://hg.netbeans.org/core-main/rev/b811364bc5c5
Comment 5 Quality Engineering 2013-03-20 02:06:42 UTC
Integrated into 'main-golden', will be available in build *201303192300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/b811364bc5c5
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #213855 - git pull --rebase
when pull requires a merge commit, offering the option do the merge or rebase
Comment 6 markiewb 2013-08-01 15:19:04 UTC
Verified in 201307312300


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo