Bug 213743 - Nullpointer when right-clicking 'Home' in favorites
Nullpointer when right-clicking 'Home' in favorites
Status: RESOLVED DUPLICATE of bug 207060
Product: platform
Classification: Unclassified
Component: Filesystems
7.2
PC Windows XP
: P2 (vote)
: 7.2
Assigned To: Jaroslav Tulach
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 12:16 UTC by woozong
Modified: 2012-06-07 15:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description woozong 2012-06-07 12:16:33 UTC
I'm running Netbeans 7.2 beta and have the following problem (which did NOT occur in NB 7.1).

When I right-click the 'Home' folder in the Favorites window, a NullPointerException is thrown. 
For info: my Home folder is on a network share (i.e. \\server\some\path).

Here's the nullpointer I get: 

java.lang.NullPointerException
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.getFileObject(FolderObj.java:126)
	at org.netbeans.modules.project.ant.AntBasedProjectFactorySingleton.loadProject(AntBasedProjectFactorySingleton.java:229)
	at org.netbeans.api.project.ProjectManager.createProject(ProjectManager.java:365)
	at org.netbeans.api.project.ProjectManager.access$300(ProjectManager.java:85)
	at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:286)
	at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:233)
	at org.openide.util.Mutex.readAccess(Mutex.java:332)
	at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:233)
	at org.netbeans.modules.projectapi.SimpleFileOwnerQueryImplementation.getOwner(SimpleFileOwnerQueryImplementation.java:127)
	at org.netbeans.api.project.FileOwnerQuery.getOwner(FileOwnerQuery.java:104)
	at org.netbeans.modules.project.ui.actions.ActionsUtil.getProjectsFromLookup(ActionsUtil.java:101)
	at org.netbeans.modules.project.ui.actions.NewFile.fillSubMenu(NewFile.java:228)
	at org.netbeans.modules.project.ui.actions.NewFile$WithSubMenu$DynaMenu.getMenuPresenters(NewFile.java:410)
	at org.netbeans.modules.openide.awt.DefaultAWTBridge.convertComponents(DefaultAWTBridge.java:120)
	at org.openide.util.Utilities.actionsToPopup(Utilities.java:2774)
	at org.openide.util.Utilities.actionsToPopup(Utilities.java:2850)
	at org.openide.explorer.view.TreeView.createPopup(TreeView.java:1058)
	at org.openide.explorer.view.TreeView$PopupAdapter.showPopup(TreeView.java:1554)
	at org.openide.awt.MouseUtils$PopupMouseAdapter.maybePopup(MouseUtils.java:189)
	at org.openide.awt.MouseUtils$PopupMouseAdapter.mouseReleased(MouseUtils.java:184)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:273)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
	at java.awt.Component.processMouseEvent(Component.java:6289)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6054)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4652)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4482)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4577)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
	at java.awt.Container.dispatchEventImpl(Container.java:2085)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4482)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:644)
	at java.awt.EventQueue.access$000(EventQueue.java:85)
	at java.awt.EventQueue$1.run(EventQueue.java:603)
	at java.awt.EventQueue$1.run(EventQueue.java:601)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:98)
	at java.awt.EventQueue$2.run(EventQueue.java:617)
	at java.awt.EventQueue$2.run(EventQueue.java:615)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:614)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:158)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
[catch] at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Comment 1 Marian Mirilovic 2012-06-07 15:45:03 UTC

*** This bug has been marked as a duplicate of bug 207060 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo