Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 213672 - No dependency on org.openide.util set when creating JPanel form in module
No dependency on org.openide.util set when creating JPanel form in module
Status: RESOLVED DUPLICATE of bug 196497
Product: guibuilder
Classification: Unclassified
Component: Code
7.2
PC Windows 7
: P3 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 14:07 UTC by mienamoo
Modified: 2012-06-06 14:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mienamoo 2012-06-06 14:07:28 UTC
NetBeans build 201206050001
JDK 7u3 32-bit

I created a standalone, Ant-based NetBeans Platform module. And in it I created a JPanel form, and I put a JLabel and a JTextField on it. The code was generated correctly, but no dependency was set on the module Utilities API (org.openide.util). The generated code uses

org.openide.util.NbBundle()

from the util module, which means that the module will not compile without having to fix the dependency manually. Could this dependency be added automatically during code generation?
Comment 1 Tomas Pavek 2012-06-06 14:20:39 UTC

*** This bug has been marked as a duplicate of bug 196497 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo