Bug 213490 - NoClassDefFoundError: org/openide/util/actions/CallbackSystemAction$DelegateAction
NoClassDefFoundError: org/openide/util/actions/CallbackSystemAction$DelegateA...
Status: RESOLVED DUPLICATE of bug 211962
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.1
All All
: P3 (vote)
: TBD
Assigned To: Vince Kraemer
issues@serverplugins
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 08:10 UTC by Exceptions Reporter
Modified: 2012-06-04 08:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.09 KB, text/plain)
2012-06-04 08:10 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-06-04 08:10:44 UTC
This issue was reported manually by mmirilovic.
It already has 28 duplicates 


Build: NetBeans IDE 7.1.1 (Build 201203012225)
VM: Java HotSpot(TM) Client VM, 22.1-b02, Java(TM) SE Runtime Environment, 1.7.0_03-b05
OS: Windows 7

User Comments:
GUEST: fix error

GUEST: There's a big problem with the new IDE running on Windows. After you make deploy and then close the browser, the basic functionality of de IDE stops.

GUEST: After installing and downloading JUnit it hangs

SEVERE [global]
java.lang.NoClassDefFoundError: org/openide/util/actions/CallbackSystemAction$DelegateAction
	at org.openide.util.actions.CallbackSystemAction.createContextAwareInstance(CallbackSystemAction.java:284)
	at org.openide.util.Utilities.actionsToPopup(Utilities.java:2762)
	at org.openide.util.Utilities.actionsToPopup(Utilities.java:2858)
	at org.openide.explorer.view.TreeView.createPopup(TreeView.java:1070)
	at org.openide.explorer.view.TreeView$PopupAdapter.showPopup(TreeView.java:1558)
	at org.openide.awt.MouseUtils$PopupMouseAdapter.maybePopup(MouseUtils.java:189)
	at org.openide.awt.MouseUtils$PopupMouseAdapter.mouseReleased(MouseUtils.java:184)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:290)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.

GUEST: When I trying to test the webservice in serverside.

GUEST: Trying to right click on Web Sevice Reference item, similar to my previos report it started to happen after upgrade of glassfish or installation of third party software

GUEST: Click right to create a package

GUEST: I just created a Web Service from WSDL.
Wsdl is correct (according to some commercial validators), and i get no error in the logs, but the menu with "test the service" action does not appear when i right-click on the webservice.




Stacktrace: 
java.lang.NoClassDefFoundError: org/openide/util/actions/CallbackSystemAction$DelegateAction
   at org.openide.util.actions.CallbackSystemAction.createContextAwareInstance(CallbackSystemAction.java:284)
   at org.openide.util.Utilities.actionsToPopup(Utilities.java:2762)
   at org.openide.util.Utilities.actionsToPopup(Utilities.java:2858)
   at org.openide.explorer.view.TreeView.createPopup(TreeView.java:1070)
   at org.openide.explorer.view.TreeView$PopupAdapter.showPopup(TreeView.java:1558)
   at org.openide.awt.MouseUtils$PopupMouseAdapter.maybePopup(MouseUtils.java:189)
Comment 1 Exceptions Reporter 2012-06-04 08:10:49 UTC
Created attachment 120280 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-06-04 08:14:28 UTC
Using glassfish?
Comment 3 Vince Kraemer 2012-06-04 08:22:33 UTC
this looks like a dup...  I see multiple notes about web services in the exception reports.

*** This bug has been marked as a duplicate of bug 211962 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo