Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 213482 - OutOfMemoryError: GC overhead limit exceeded
OutOfMemoryError: GC overhead limit exceeded
Status: RESOLVED DUPLICATE of bug 213860
Product: ide
Classification: Unclassified
Component: Performance
7.2
PC Mac OS X
: P2 (vote)
: TBD
Assigned To: Tomas Hurka
issues@performance
issue_reviewed
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 07:30 UTC by Petr Jiricka
Modified: 2012-06-13 09:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2012-06-04 07:30:55 UTC
I got an OOME, not sure how to reproduce. Originally filed as a part of bug 212687, splitting into a separate issue for better legibility.

Here is some relevant information:

Thread dump + some more diagnostic information: http://netbeans.org/bugzilla/attachment.cgi?id=119598

IDE log file: http://netbeans.org/bugzilla/attachment.cgi?id=119600

Head dump:
http://deadlock.netbeans.org/hudson/job/heap_dumps/ws/Issue212687_2012-06-01_02-02-55_1dcfe016b3a3f1255be98bc6f91d1496.zip
(Note: rename the heap_dump file included in the zip to heap_dump.zip, as it is
itself a zip containing file heapdump.hprof.)
Comment 1 Petr Cyhelsky 2012-06-11 06:12:14 UTC
Sorry, but I am unable to download the heap dump from deadlock, can it be obtained from somewhere else?
Comment 2 Petr Cyhelsky 2012-06-13 09:26:22 UTC
it seems that the oome was dealt with in Issue#213860. As this is no longer a problem I'm setting this issue as duplicate.

*** This bug has been marked as a duplicate of bug 213860 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo