Bug 213448 - LowPerformance took 4885 ms.
LowPerformance took 4885 ms.
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 14:01 UTC by Exceptions Reporter
Modified: 2012-06-04 07:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (41.02 KB, application/nps)
2012-06-03 14:01 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-06-03 14:01:42 UTC
Build: NetBeans IDE 7.2 Beta (Build 201205031832)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b22
OS: Windows NT (unknown)

User Comments:
tnleeuw: Start editing a (small) Java file; first time doing so this IDE session.

OndrejBrejla: Just started IDE.

GUEST: copy paste of a chunk of code....



Maximum slowness yet reported was 15844 ms, average is 7059
Comment 1 Exceptions Reporter 2012-06-03 14:01:48 UTC
Created attachment 120255 [details]
nps snapshot
Comment 2 Dusan Balek 2012-06-04 07:58:53 UTC
As can be seen from the attached snapshots, AWT EDT is blocked inside BaseKit.InsertBreakAction waiting for an extremely slow class loading caused by high IO load.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo