Bug 213434 - NullPointerException at org.netbeans.modules.html.editor.completion.HtmlCompletionProvider$DocQuery.doQuery
NullPointerException at org.netbeans.modules.html.editor.completion.HtmlCompl...
Status: RESOLVED FIXED
Product: web
Classification: Unclassified
Component: HTML Editor
7.2
All All
: P3 (vote)
: TBD
Assigned To: PetrPodzimek
issues@javaee
EXCEPTIONS_REPORT
:
: 214673 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 19:28 UTC by schkovich
Modified: 2012-09-14 12:36 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (645 bytes, text/plain)
2012-06-02 19:28 UTC, schkovich
Details
stacktrace (645 bytes, text/plain)
2012-06-04 06:43 UTC, schkovich
Details
stacktrace (645 bytes, text/plain)
2012-06-04 16:28 UTC, mcneill.cc
Details
stacktrace (645 bytes, text/plain)
2012-06-04 17:28 UTC, mcneill.cc
Details
stacktrace (645 bytes, text/plain)
2012-06-04 17:58 UTC, jyeary
Details
stacktrace (645 bytes, text/plain)
2012-06-05 22:37 UTC, host
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-06-02 19:28:43 UTC
Build: NetBeans IDE Dev (Build 201206020001)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: auto completion




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.html.editor.completion.HtmlCompletionProvider$DocQuery.doQuery(HtmlCompletionProvider.java:232)
   at org.netbeans.modules.html.editor.completion.HtmlCompletionProvider$AbstractQuery.query(HtmlCompletionProvider.java:281)
   at org.netbeans.spi.editor.completion.support.AsyncCompletionTask.run(AsyncCompletionTask.java:223)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032)
Comment 1 schkovich 2012-06-02 19:28:49 UTC
Created attachment 120246 [details]
stacktrace
Comment 2 schkovich 2012-06-04 06:43:14 UTC
Created attachment 120275 [details]
stacktrace

back space during code completion wondering about class constants defined
Comment 3 Exceptions Reporter 2012-06-04 06:43:32 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=188863
Comment 4 Marek Fukala 2012-06-04 11:51:57 UTC
regression of the issue #212989 fix
Comment 5 mcneill.cc 2012-06-04 16:28:18 UTC
Created attachment 120332 [details]
stacktrace
Comment 6 mcneill.cc 2012-06-04 17:28:17 UTC
Created attachment 120333 [details]
stacktrace

Saving an edit to jsp file.
Comment 7 jyeary 2012-06-04 17:58:14 UTC
Created attachment 120335 [details]
stacktrace

Code completion.
Comment 8 Exceptions Reporter 2012-06-05 06:22:15 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=188863
Comment 9 PetrPodzimek 2012-06-05 13:37:08 UTC
web-main#6eefa317a526
Comment 10 host 2012-06-05 22:37:14 UTC
Created attachment 120398 [details]
stacktrace
Comment 11 Quality Engineering 2012-06-08 06:11:20 UTC
Integrated into 'main-golden', will be available in build *201206080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6eefa317a526
User: Petr Podzimek <PetrPodzimek@netbeans.org>
Log: #213434 - NullPointerException at org.netbeans.modules.html.editor.completion.HtmlCompletionProvider$DocQuery.doQuery
Comment 12 kolen 2012-06-08 08:53:39 UTC
Seems that not occuring anymore in 201206080001.
Comment 13 Marek Fukala 2012-09-14 12:36:25 UTC
*** Bug 214673 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo