Bug 213352 - IllegalArgumentException: URI has an authority component
IllegalArgumentException: URI has an authority component
Status: RESOLVED DUPLICATE of bug 213562
Product: platform
Classification: Unclassified
Component: Filesystems
7.2
PC Windows XP
: P3 (vote)
: 7.2
Assigned To: Jesse Glick
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 23:37 UTC by Jesse Glick
Modified: 2012-06-08 06:05 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.93 KB, text/plain)
2012-05-31 23:37 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-05-31 23:37:40 UTC
Build: NetBeans IDE Dev (Build 20120531-962cece4032b)
VM: Java HotSpot(TM) Client VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b22
OS: Windows XP

Stacktrace: 
java.lang.IllegalArgumentException: URI has an authority component
   at java.io.File.<init>(File.java:397)
   at org.openide.filesystems.FileUtil.archiveOrDirForURL(FileUtil.java:2198)
   at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$AbstractRootsWork.scanSources(RepositoryUpdater.java:4515)
   at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$RootsWork.getDone(RepositoryUpdater.java:4202)
   at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:2940)
   at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task._run(RepositoryUpdater.java:5176)
Comment 1 Jesse Glick 2012-05-31 23:37:46 UTC
Created attachment 120170 [details]
stacktrace
Comment 2 Tomas Zezula 2012-06-01 08:38:05 UTC
>OS: Windows XP
Probably related to your OS upgrade ;-)
Fixed jet-main 6fc65c1ecff3
Comment 3 Jesse Glick 2012-06-01 13:44:57 UTC
This fix is wrong, please revert and reassign to platform/filesystems; archiveOrDirForURL is not permitted to throw IAE.
Comment 4 Quality Engineering 2012-06-02 06:09:33 UTC
Integrated into 'main-golden', will be available in build *201206020001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6fc65c1ecff3
User: Tomas Zezula <tzezula@netbeans.org>
Log: #213352:IllegalArgumentException: URI has an authority component
Comment 5 Tomas Zezula 2012-06-04 09:25:39 UTC
jet-main a03cfd37109c  : expecting that archiveOrDirForURL does not throw IAE.
Comment 6 Jesse Glick 2012-06-06 21:03:29 UTC
Will be fixed as part of bug #213562.

*** This bug has been marked as a duplicate of bug 213562 ***
Comment 7 Quality Engineering 2012-06-08 06:05:10 UTC
Integrated into 'main-golden', will be available in build *201206080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a03cfd37109c
User: Tomas Zezula <tzezula@netbeans.org>
Log: #213352:IllegalArgumentException: URI has an authority component


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo